Bug 4859 - Abstract and Paper submission review problems
Abstract and Paper submission review problems
Status: RESOLVED DUPLICATE of bug 4913
Product: OCS
Classification: Unclassified
Component: Review
2.1.3
PC Mac OS X 10.3
: P5 major
Assigned To: PKP Support
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-11-03 11:43 PST by James MacGregor
Modified: 2009-12-01 15:39 PST (History)
3 users (show)

See Also:
Version Reported In: 2.1.2
Also Affects:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description James MacGregor 2009-11-03 11:43:07 PST
Using "Abstract and Paper together" submission types results in problems when choosing either Revisions Required or Decline Submission Director Decision options. 

This one is a little tricky to diagnose, but I think the following steps replicate it: 

-- for submission type, choose Abstract and Review together. 

-- Submit a paper; assign the submission to a Director/Track Director. 

-- select a Reviewer; have them go through the review process. 

-- If, after the review process, the Director chooses "Revisions Required", the page reloads; the Record Decision button is greyed out/unclickable; the Director Decision reads "None"; and under Peer Review, it says "It's not yet possible to perform this review. Either the abstract review is not yet complete, or the author has not yet provided a paper for review." Note that I haven't even sent an email to the author yet. 

If I send an email to the Author, clicking Import Peer Reviews reloads the page, but nothing appears. 

If I upload an author version, still nothing is unstuck. 

-- The same thing happens when I choose "Decline Review."

I'm wondering if there should be an both an Abstract and a Paper review page available to Track Directors for this kind of workflow? The system appears to want a discrete abstract review signed off on, but there's no way to do this currently.
Comment 1 Alec Smecher 2009-12-01 12:39:10 PST
James, this might be a dupe of bug #4913 -- could you check a fresh update (or the translation install) to see if you can still cause this behavior?
Comment 2 James MacGregor 2009-12-01 15:39:09 PST
(In reply to comment #1)
> James, this might be a dupe of bug #4913 -- could you check a fresh update (or
> the translation install) to see if you can still cause this behavior?

Hi Alec -- yep, this works now. Thanks!

*** This bug has been marked as a duplicate of bug 4913 ***