Bug 4809 - selections are toggled when clicking [Select All] when choosing articles or issues to export
selections are toggled when clicking [Select All] when choosing articles or i...
Status: RESOLVED WONTFIX
Product: OJS
Classification: Unclassified
Component: Import/Export
To be determined
PC Linux
: P5 minor
Assigned To: PKP Support
: 3480 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-10-09 13:38 PDT by Ryan Yeske
Modified: 2013-05-29 16:10 PDT (History)
2 users (show)

See Also:
Version Reported In:
Also Affects:


Attachments
select all articles and issues, dont toggle selections (1.63 KB, patch)
2009-10-09 13:38 PDT, Ryan Yeske
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Ryan Yeske 2009-10-09 13:38:19 PDT
Created attachment 2518 [details]
select all articles and issues, dont toggle selections

When using the NativeImportExportPlugin, if you manually select one article and then click [Select All], all of the other articles are selected, and your original selection is deselected.  This is not what I expected when clicking that button.  Either the button should be renamed, or it should actually select all.  If the latter, perhaps we should add a [deselect all] button.

Attached is a patch that changes the behaviour to select all articles/issues.
Comment 1 Alec Smecher 2012-09-24 08:47:13 PDT
*** Bug 3480 has been marked as a duplicate of this bug. ***
Comment 2 Alec Smecher 2013-05-29 16:10:18 PDT
The current "select all" code is superseded by new UI work.