We are moving to Git Issues for bug tracking in future releases. During transition, content will be in both tools. If you'd like to file a new bug, please create an issue.

Bug 4718 - Allow editors to modify article publication date
Allow editors to modify article publication date
Status: RESOLVED FIXED
Product: OJS
Classification: Unclassified
Component: Editors
2.3.5
PC Linux
: P5 enhancement
Assigned To: Michael Felczak
: 6553 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-09-04 13:26 PDT by Michael Felczak
Modified: 2011-04-04 14:08 PDT (History)
5 users (show)

See Also:
Version Reported In:
Also Affects:


Attachments
Patch against OJS 2.3.4 (18.15 KB, patch)
2011-03-08 08:32 PST, Alec Smecher
Details | Diff
Additional patch against OJS 2.3.4 (2.62 KB, patch)
2011-04-04 14:08 PDT, Alec Smecher
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Felczak 2009-09-04 13:26:55 PDT
For content imported via the new expedited submission process, the article
publication date will be the current date. Editors can modify the issue
publication date for past issues, but not the article publication date.

Also add option next to edit of issue publication date that will allow Editors to propagate edited issue publication date to all articles in the TOC. This will speed-up and simply workflow and not require that Editors edit each article publication date one by one.
Comment 1 Michael Felczak 2009-09-04 13:27:41 PDT
Courtesy of http://pkp.sfu.ca/support/forum/viewtopic.php?f=8&t=4218#p19234
Comment 2 James MacGregor 2011-02-16 14:24:08 PST
Rescheduled to 2.3.5 due to reports from Coaction and Google Scholar.
Comment 3 Alec Smecher 2011-03-08 08:32:34 PST
Created attachment 3447 [details]
Patch against OJS 2.3.4

Requires a DB change to make published_articles.date_published nullable:

ALTER TABLE published_articles CHANGE COLUMN date_published date_published DATETIME;

See bug #6480 for related changes.
Comment 4 Alec Smecher 2011-03-08 15:45:05 PST
(Committed to ojs-stable-2_3)
Comment 5 Alec Smecher 2011-04-04 14:08:19 PDT
Created attachment 3479 [details]
Additional patch against OJS 2.3.4
Comment 6 Alec Smecher 2011-04-04 14:08:29 PDT
*** Bug 6553 has been marked as a duplicate of this bug. ***