Bug 4046 - MLA Citation style revisions
MLA Citation style revisions
Status: RESOLVED DUPLICATE of bug 5003
Product: OJS
Classification: Unclassified
Component: Reading Tools
To be determined
PC Windows NT
: P5 enhancement
Assigned To: PKP Support
http://postcolonial.org/index.php/pct...
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-05 10:39 PST by Kevin Stranack
Modified: 2010-01-14 20:49 PST (History)
1 user (show)

See Also:
Version Reported In:
Also Affects:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Kevin Stranack 2009-02-05 10:39:34 PST
The MLA citations created in the Reading Tools are incorrect. Here are the necessary revisions:

1. AND should not be capitalized between authors

2. Only the first author is Lastname, Firstname -- all others are Firstname Lastname.

3. The should be a period between the last letter of the article title and the closing quotation mark.

4. [Online] should be removed.

5. There should be no comma after the journal title.

6. The volume number and issue number should be separated by a period, with no spaces.

7. The year of publication should be in parentheses.

8. After the year parentheses, there should be a colon, followed by the access date.

Note: If page numbers are available, they should follow the colon and end in a period. E.g., (2008): 24-36. 05 Feb. 2009

9. The access date information should be the current date -- if the reader is viewing the citation on 05 Feb 2009, then that should be the date that displays.

10. The month abbreviation should be followed by a period.

11. After the access date, there should be a space and the the article level URL in angle brackets, and end in a period.

Note: The journal title is correctly italicized and should stay that way.

I think that is everything.

Current:
Smart, Robert, AND Hutcheson, Michael. "Suspect Grounds: Temporal and Spatial Paradoxes in Bram Stoker’s Dracula: a Postcolonial Reading" Postcolonial Text [Online], 3 7 Jan 2008 

Revised:
Smart, Robert, and Michael Hutcheson. "Suspect Grounds: Temporal and Spatial Paradoxes in Bram Stoker’s Dracula: a Postcolonial Reading." Postcolonial Text 3.7 (2008): 05 Feb. 2009 <http://postcolonial.org/index.php/pct/article/view/710>.
Comment 1 Juan Pablo Alperin 2010-01-14 20:49:35 PST

*** This bug has been marked as a duplicate of bug 5003 ***