Bug 3999 - Using "Select All" button in conjunction with export plugins produces error(s)
Using "Select All" button in conjunction with export plugins produces error(s)
Status: RESOLVED FIXED
Product: OJS
Classification: Unclassified
Component: Import/Export
2.2.3
PC Mac OS X 10.0
: P1 normal
Assigned To: Alec Smecher
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-13 10:34 PST by James MacGregor
Modified: 2009-02-04 15:46 PST (History)
2 users (show)

See Also:
Version Reported In:
Also Affects:


Attachments
Patch against OJS pre-2.2.3 CVS (1.05 KB, patch)
2009-02-04 15:41 PST, Alec Smecher
Details | Diff
Patch against OCS pre-2.1.2 CVS (1016 bytes, patch)
2009-02-04 15:44 PST, Alec Smecher
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description James MacGregor 2009-01-13 10:34:52 PST
With the Crossref, Pubmed and Articles/Issues plugins: 

-- If I choose to export issues; click "Select All"; and then click the Export button, I am not presented with an XML download but am returned to the Import/Export plugins page. 

-- If I choose to export articles; click "Select All"; and then click the Export button, I receive the following error: 

Fatal error: Call to a member function getSectionId() on a non-object in /Users/jmacgreg/Sites/stable/ojs-rel/classes/search/ArticleSearch.inc.php on line 255

This *only* happens when the Select All button is clicked. If I manually check each item to export (regardless of whether I'm checking an article or issue) the download works. 

Heads-up courtesy of http://pkp.sfu.ca/support/forum/viewtopic.php?f=8&p=15313#p15313.
Comment 1 Alec Smecher 2009-02-04 15:41:49 PST
Created attachment 1397 [details]
Patch against OJS pre-2.2.3 CVS
Comment 2 Alec Smecher 2009-02-04 15:44:06 PST
Created attachment 1398 [details]
Patch against OCS pre-2.1.2 CVS
Comment 3 Alec Smecher 2009-02-04 15:46:01 PST
Bug is caused by a DB inconsistency with a single article, not by the use or otherwise of the "Select All" button; added a sanity check.