We are moving to Git Issues for bug tracking in future releases. During transition, content will be in both tools. If you'd like to file a new bug, please create an issue.

Bug 3947 - email: Section Editors should receive notification of submission to their assigned section
email: Section Editors should receive notification of submission to their ass...
Status: RESOLVED DUPLICATE of bug 2680
Product: OJS
Classification: Unclassified
Component: Framework
2.3
PC Mac OS X 10.0
: P1 normal
Assigned To: PKP Support
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-27 13:19 PST by James MacGregor
Modified: 2008-12-27 14:25 PST (History)
0 users

See Also:
Version Reported In:
Also Affects:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description James MacGregor 2008-12-27 13:19:08 PST
If an Editor assigns a Section Editor to a submission, they must send a notification email (EDITOR_ASSIGN), which provides a link as well as a notification that a submission has been assigned. However, if a SE is assigned to a Journal Section, they are automatically assigned the submission but receive no notification email. Perhaps the EDITOR_ASSIGN email should be sent out automatically if this is the case. 

Additionally: I'm not entirely sure on this following point but it seemed to happen while I ran a few tests: if a Section Editor is assigned to a section, and if Journal Setup Step 3.6 is checked so that the author notification email should go to the Primary Contact, the email also appears to go to the Section Editor. This may be a decent enough compromise for notification, but just the same it's probably better to have an Editorial Notification email sent out, rather than the Notification of Author Submission email. 

Courtesy of John Maxwell: http://pkp.sfu.ca/support/forum/viewtopic.php?f=2&p=15086#p15086

Also related to Bug 3922.
Comment 1 Alec Smecher 2008-12-27 14:14:14 PST
I would suggest CC'ing automatically assigned section editors on the original submission acknowledgement.
Comment 2 John Willinsky 2008-12-27 14:19:49 PST
Agreed on cc-ing section editors who are assigned responsibility for Review stage. 
Comment 3 Alec Smecher 2008-12-27 14:25:09 PST
This should already be the case in CVS as per bug #2680.

*** This bug has been marked as a duplicate of bug 2680 ***