We are moving to Git Issues for bug tracking in future releases. During transition, content will be in both tools. If you'd like to file a new bug, please create an issue.

Bug 3765 - Back-port review forms to OCS
Back-port review forms to OCS
Status: RESOLVED FIXED
Product: OCS
Classification: Unclassified
Component: Review
2.1.2
PC Linux
: P1 normal
Assigned To: PKP Support
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-12 12:41 PDT by Alec Smecher
Modified: 2009-02-13 11:03 PST (History)
1 user (show)

See Also:
Version Reported In:
Also Affects:


Attachments
patch against OCS pre-2.1.2 CVS (178.60 KB, patch)
2008-09-18 12:48 PDT, Matthew Crider
Details | Diff
Patch against OCS Pre-2.3 CVS (178.88 KB, patch)
2008-09-19 14:40 PDT, Matthew Crider
Details | Diff
Patch against OCS Pre-2.1.2 CVS (1.50 KB, patch)
2008-10-06 17:15 PDT, Matthew Crider
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Alec Smecher 2008-09-12 12:41:53 PDT
Back-port review forms to OCS
Comment 1 Matthew Crider 2008-09-18 12:48:35 PDT
Created attachment 967 [details]
patch against OCS pre-2.1.2 CVS
Comment 2 Matthew Crider 2008-09-19 14:40:20 PDT
Created attachment 968 [details]
Patch against OCS Pre-2.3 CVS
Comment 3 Alec Smecher 2008-09-22 09:59:06 PDT
Looks great, Matt! I'll wait to commit this until OCS 2.1.1 has been released.
Comment 4 Alec Smecher 2008-09-26 09:16:10 PDT
OJS bug #3790 needs to be back-ported once these changes are committed.
Comment 5 Matthew Crider 2008-10-06 15:38:48 PDT
(In reply to comment #4)
> OJS bug #3790 needs to be back-ported once these changes are committed.
> 

I'm not getting the same errors as reported in bug 3790 and bug 3796 -- Am I missing something?  Does the review form backport fix this problem already (I.e. review_form ids are null by default)?  Otherwise I have a backport waiting (I probably should've tried to reproduce the behavior before I did that!).
Comment 6 Alec Smecher 2008-10-06 15:53:06 PDT
This should be a fairly straight-across back port -- I believe that only some versions of MySQL complain about it, so that might explain why you're not getting the same problem. It's worth keeping the code synced anyway, even if you can't reproduce the problem.
Comment 7 Matthew Crider 2008-10-06 17:15:13 PDT
Created attachment 1013 [details]
Patch against OCS Pre-2.1.2 CVS
Comment 8 Alec Smecher 2008-10-10 15:28:50 PDT
Committed attachment #967 [details] and attachment #1013 [details] to OCS2 devel tree.
Comment 9 Alec Smecher 2008-10-17 09:28:57 PDT
Bug #3821 needs to be back-ported (locale key changes for review forms).
Comment 10 Alec Smecher 2008-10-17 14:34:52 PDT
Bug #3821 back-ported to devel tree.

Review forms not yet committed to stable tree, but everything else is done.
Comment 11 Matthew Crider 2008-10-28 20:38:36 PDT
Committed to stable tree (along with Bug #3821).
Comment 12 Alec Smecher 2009-02-13 11:01:22 PST
Matt, can this entry be closed?
Comment 13 Matthew Crider 2009-02-13 11:03:40 PST
I'm going to go with yes.