Bug 3396 - Subscription status block
Subscription status block
Status: RESOLVED FIXED
Product: OJS
Classification: Unclassified
Component: Subscriptions
2.2.1
All All
: P1 enhancement
Assigned To: Juan Pablo Alperin
: 3021 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-21 10:44 PDT by Michael Felczak
Modified: 2008-05-11 10:55 PDT (History)
1 user (show)

See Also:
Version Reported In:
Also Affects:


Attachments
proposed subscription block - patch against CVS (6.54 KB, patch)
2008-05-10 14:11 PDT, Juan Pablo Alperin
Details | Diff
a second proposed patch against CVS (ignores previous patch) (8.38 KB, patch)
2008-05-10 18:44 PDT, Juan Pablo Alperin
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Felczak 2008-04-21 10:44:04 PDT
Add an optional block that will display the following info for subscriptions:

User: if logged in and non-institutional subscription type, show the subscription type, start, and end date.

Institution: name of the institution and IP address of where user is coming from (i.e. one of the institution's IP addresses set for the subscription).

See http://pkp.sfu.ca/support/forum/viewtopic.php?f=9&p=10808#p10808
Comment 1 Juan Pablo Alperin 2008-04-25 17:36:08 PDT
*** Bug 3021 has been marked as a duplicate of this bug. ***
Comment 2 Michael Felczak 2008-05-04 12:41:48 PDT
As we discussed, reassigning to you, Juan.
Comment 3 Juan Pablo Alperin 2008-05-10 14:11:47 PDT
Created attachment 640 [details]
proposed subscription block - patch against CVS

Michael, what do you think of this logic?

- if there is membership information in the subscription, display that.  If there isn't, display the IP.  
- the other idea is to check in the plugin itself how the subscription was recognized (i.e. by user, by domain, or by IP).  But this seemed to make things unnecessarily complicated.

Thoughts?
Comment 4 Michael Felczak 2008-05-10 14:37:46 PDT
Hi, Juan. I think the latter is preferable simply because I think we want to display different information based on the subscription type that is being used for the authentication.

That is, for an individual subscription it's informative to display to the user the start and end date so that the user can see it and perhaps consider renewing the subscription if the end date is near. In contrast, we wouldn't want to display the start and end date for institutional subscriptions, since the renewal and record details are between the journal and the institution, not any individual user accessing via institutional affiliation.

My suggestion would be something along these lines for an individual:
- Subscription type
- Start and end date
- membership info, if present

For an institution:
- Some indicator that authentication is via institution (e.g. "Access via institutional subscription")
- IP address of where user is coming from

To clearly mark this in the sidebar, I think it also makes sense to follow the convention of including a title (e.g. "Subscription") for the block (similar to "User" or "Editor" etc.) ...
Comment 5 Juan Pablo Alperin 2008-05-10 18:44:28 PDT
Created attachment 641 [details]
a second proposed patch against CVS (ignores previous patch)

This handles things a little better.  I chose not to put the start date of the subscription, since I think its the expiry date that is of bigger concern and I did not want to bulk up the block too much.  I did, however, add a link for payment if the logged-in user is the one that 'owns' the subscription.
Comment 6 Juan Pablo Alperin 2008-05-10 18:50:20 PDT
Added attachment #641 [details] (second patch) to CVS.  

Closing, but someone may want to tweak the UI.
Comment 7 Juan Pablo Alperin 2008-05-10 18:52:00 PDT
Comment on attachment 640 [details]
proposed subscription block - patch against CVS

obsoleting this patch in light of the second one submitted
Comment 8 Michael Felczak 2008-05-11 10:54:51 PDT
Looks excellent, Juan. I haven't tested extensively, but I think we should also handle the case where the user has a subscription that has expired and display this info in the status block (i.e., Expired: date).

If payments are enabled, we could then also display the payment link to give the user an opportunity to renew the expired subscription.