Bug 3321 - Galley upload form languages list can be empty
Galley upload form languages list can be empty
Status: RESOLVED FIXED
Product: OJS
Classification: Unclassified
Component: Localization
2.2.1
Macintosh Mac OS X 10.3
: P1 normal
Assigned To: PKP Support
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-02 16:36 PDT by Siavash Miri
Modified: 2008-07-14 09:50 PDT (History)
0 users

See Also:
Version Reported In:
Also Affects:


Attachments
Patch against pre-2.2.1 CVS (1.90 KB, patch)
2008-04-04 03:08 PDT, Alec Smecher
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Siavash Miri 2008-04-02 16:36:37 PDT
In the "Edit a Layout Galley Page" the users are asked to choose a locale before they can continue, but no locale is available in the drop down menu. As a SA you can see the supported locale; However, if only one locale is supported, then the JM doesn't see any available locales in JM's languages page.


Norm on the support forums has found a solution and I had to use his solution for Current Oncology and it worked.

http://pkp.sfu.ca/support/forum/viewtopic.php?f=8&t=2612&p=10602#p10586


Seems like the problem only occurs when there's only one locale supported. So if we add a second locale as SA, then in the JM's languages page both locales show up. For Current oncology, I installed the french locale, and that made both locales show up in JM's languages page. From there I unchecked the french locale box under supported locales and it made everything ok.
Comment 1 Alec Smecher 2008-04-04 03:08:19 PDT
Created attachment 551 [details]
Patch against pre-2.2.1 CVS

This was caused by a potentially missing supportedLocales setting for journals created prior to OJS 2.2 that only use a single language. This patch corrects the upgrade process, but journals that have already upgraded will need the following work-around:

1. As Site Admin, use the site-wide Languages page to install and enable a second language. (Any will do.)
2. As Journal Manager, for each affected journal, use the Languages page to set the journal's language options as desired. (It is not necessary to choose a second language for this to work.)
3. As Site Admin, return the site-wide Languages page to desired settings (i.e. disable the second language).
Comment 2 Alec Smecher 2008-04-04 03:11:07 PDT
Fixed.