Bug 3108 - Default settings not loaded for new locales when added post journal creation
Default settings not loaded for new locales when added post journal creation
Status: RESOLVED FIXED
Product: OCS
Classification: Unclassified
Component: General
2.3
PC Mac OS X 10.0
: P1 normal
Assigned To: Ryan Yeske
: 3598 3645 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-25 08:18 PDT by Juan Pablo Alperin
Modified: 2009-10-23 14:57 PDT (History)
5 users (show)

See Also:
Version Reported In:
Also Affects:


Attachments
patch against CVS (11.50 KB, patch)
2008-05-20 15:44 PDT, Juan Pablo Alperin
Details | Diff
patch against ocs2 cvs (12.33 KB, patch)
2009-10-22 16:12 PDT, Ryan Yeske
Details | Diff
patch against ocs2 cvs (12.36 KB, patch)
2009-10-22 16:25 PDT, Ryan Yeske
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Juan Pablo Alperin 2007-10-25 08:18:40 PDT
If a journal exists only in one language, and a new language is added later, the default settings should be loaded for that new locale.
Comment 1 Juan Pablo Alperin 2008-05-20 15:00:04 PDT
Proposed functionality is to provide the OPTION to reload default settings (only localizable items) for each locale that is enabled and NOT to load these by default. 

This way, JM have the option to fall back on Main Locale if they already setting there OR they can pop up the defaults. 
Comment 2 Juan Pablo Alperin 2008-05-20 15:44:15 PDT
Created attachment 655 [details]
patch against CVS

added some functions in JournalSettingsDAO similar to those already there, but with the option to specify 1 locale.  These functions do NOT reset all settings, only those that are 'localizable' according the the journalSettings.xml file.
Comment 3 Alec Smecher 2008-06-24 09:09:14 PDT
*** Bug 3598 has been marked as a duplicate of this bug. ***
Comment 4 Alec Smecher 2008-07-03 19:10:47 PDT
*** Bug 3645 has been marked as a duplicate of this bug. ***
Comment 5 Alec Smecher 2009-07-02 17:35:10 PDT
This needs to be back-ported to OCS (pre-2.3) and possibly others (?)
Comment 6 Juan Pablo Alperin 2009-07-22 19:44:25 PDT
moving to OCS
Comment 7 Ryan Yeske 2009-10-22 16:12:48 PDT
Created attachment 2543 [details]
patch against ocs2 cvs

port of Juan's ojs patch
Comment 8 Ryan Yeske 2009-10-22 16:19:29 PDT
non-en_US ocs2/locale/xx_XX/default.xml files still need to be written.

also, ##manager.language.{confirmDefaultSettingsOverwrite, reloadLocalizedDefaultSettings}## need to be added to locale/xx_XX/manager.xml (non-en_US).
Comment 9 Ryan Yeske 2009-10-22 16:25:54 PDT
Created attachment 2544 [details]
patch against ocs2 cvs

Oops, forgot to substitute occurances of 'journal' with 'conference' in comments of ConferenceSettingsDAO.inc.php
Comment 10 Alec Smecher 2009-10-22 22:44:54 PDT
Looks OK -- go ahead and commit and close.
Comment 11 Ryan Yeske 2009-10-23 14:57:48 PDT
Commit