Bug 3059 - Localization updates for OJS 2.2
Localization updates for OJS 2.2
Status: RESOLVED FIXED
Product: OJS
Classification: Unclassified
Component: Localization
2.2
PC Linux
: P1 normal
Assigned To: PKP Support
: 3066 3124 3126 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-10 13:24 PDT by Alec Smecher
Modified: 2007-12-11 12:03 PST (History)
3 users (show)

See Also:
Version Reported In:
Also Affects:


Attachments
Patch against pre-2.2 CVS (15.84 KB, patch)
2007-10-31 14:58 PDT, Alec Smecher
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Alec Smecher 2007-10-10 13:24:00 PDT
Localization updates for OJS 2.2
Comment 1 Alec Smecher 2007-10-15 13:29:31 PDT
*** Bug 3066 has been marked as a duplicate of this bug. ***
Comment 2 Ivailo Stoyanov 2007-10-25 06:06:40 PDT
On every language(locale)-related page there is listed a "Test Locale (te_ST)" -- is this a feature (e.g. placeholder for future supported languages) or a bug?
Comment 3 Alec Smecher 2007-10-25 09:00:55 PDT
Hi Ivailo -- Regarding comment #2, te_ST is a testing locale that is included in CVS but is removed from the distribution package as part of the build process.
Comment 4 Alec Smecher 2007-10-26 14:38:48 PDT
NOTE: Before closing this bug, I need to check whether new email templates, including those for plugins and payments, are inserted when necessary during the upgrade process. Also consider this for other locales.
Comment 5 Alec Smecher 2007-10-30 15:37:28 PDT
Added countries for tr_TR; added currencies for fr_CA, hr_HR, it_IT, ja_JP, ru_RU, tr_TR, and vi_VN. Added conversion tools for GNU gettext data.
Comment 6 Alec Smecher 2007-10-31 14:58:57 PDT
Created attachment 351 [details]
Patch against pre-2.2 CVS
Comment 7 Alec Smecher 2007-11-01 08:53:33 PDT
*** Bug 3124 has been marked as a duplicate of this bug. ***
Comment 8 Alec Smecher 2007-11-01 09:19:25 PDT
*** Bug 3126 has been marked as a duplicate of this bug. ***
Comment 9 Alec Smecher 2007-11-13 14:37:39 PST
Updated remaining themes.
Comment 10 Alec Smecher 2007-12-06 07:07:16 PST
Need to look into XML escaping in the translation tools more thoroughly. It looks as though tags containing explicit < and > characters (e.g. for HTML samples written in HTML) aren't getting stored properly.
Comment 11 Alec Smecher 2007-12-11 12:03:51 PST
Closing for OJS 2.2.