Bug 2961 - Localization overhaul
Localization overhaul
Status: RESOLVED FIXED
Product: OJS
Classification: Unclassified
Component: Localization
2.2
PC Linux
: P1 normal
Assigned To: PKP Support
: 3071 3074 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-26 08:28 PDT by Alec Smecher
Modified: 2007-10-16 11:39 PDT (History)
2 users (show)

See Also:
Version Reported In:
Also Affects:


Attachments
Patch against pre-2.2 CVS (333.30 KB, application/gzip)
2007-08-29 16:56 PDT, Alec Smecher
Details
Patch against pre-2.2 CVS (7.69 KB, patch)
2007-09-04 16:55 PDT, Alec Smecher
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Alec Smecher 2007-07-26 08:28:49 PDT
Overhaul metadata storage for better localization support; remove the 3-locale restriction and add support for multilingual journal, author, and article metadata.
Comment 1 Alec Smecher 2007-08-29 16:56:14 PDT
Created attachment 259 [details]
Patch against pre-2.2 CVS

First cut at internationalization changes. (Gzipped patch.)
Comment 2 Alec Smecher 2007-08-29 17:02:38 PDT
Committed first cut at localization overhaul.

Steps to update a pre-localized CVS install:
 - BACK UP YOUR DATABASE. You are warned!
 - Use tools/dbXMLtoSQL.php to apply the schema dbscripts/xml/ojs_schema_stage1.xml
 - Run classes/Upgrade.inc.php::setJournalPrimaryLocales
 - Use tools/dbXMLtoSQL.php to apply the data upgrade/2.2.0_localize.xml
 - Use Use tools/dbXMLtoSQL.php to apply the schema dbscripts/xml/ojs_schema.xml
 - Run classes/Upgrade.inc.php::localizeJournalSettings
 - Run classes/Upgrade.inc.php::migratePublisher
 - Run classes/Upgrade.inc.php::installBlockPlugins (if blocks have not yet been installed, i.e. if your sidebar disappears)
 - Run classes/Upgrade.inc.php::setGalleyLocales
 - Run classes/Upgrade.inc.php::clearDataCache

Leaving open as tracking issue.
Comment 3 Alec Smecher 2007-08-29 18:48:19 PDT
Plugins need lots of work and testing.
Comment 4 Alec Smecher 2007-09-04 16:55:10 PDT
Created attachment 265 [details]
Patch against pre-2.2 CVS

Fixed a few introduced bugs
Comment 5 Alec Smecher 2007-09-20 18:43:14 PDT
Closing -- although some bugs will certainly remain.
Comment 6 Michael Felczak 2007-09-21 15:15:42 PDT
Found another one:

Fatal error: Call to undefined method IssueDAO::updateLocaleData() in ojs2/classes/issue/IssueDAO.inc.php on line 256
Comment 7 Alec Smecher 2007-09-21 15:30:22 PDT
Fixed typo.
Comment 8 Michael Felczak 2007-09-25 20:47:16 PDT
Found some additional problems with OJS1 import:

Fatal error: Call to undefined method Journal::setTitle() in /Users/webdev/Sites/ojs2/classes/site/ImportOJS1.inc.php on line 231

Also, many warnings of the following variety:

Warning: Missing argument 2 for Issue::setTitle(), called in classes/site/ImportOJS1.inc.php on line 801

Warning: Missing argument 2 for Issue::setDescription(), called in classes/site/ImportOJS1.inc.php on line 822
Comment 9 Alec Smecher 2007-09-26 09:34:15 PDT
Fixed issues mentioned in comment #8.
Comment 10 Michael Felczak 2007-09-28 14:21:41 PDT
Alec, the latest update seems to break the import altogether:

DB Error: Column 'journal_id' cannot be null

Stack Trace:
File: ojs2/classes/journal/JournalSettingsDAO.inc.php line 138
Function: DAO->update("INSERT INTO journal_settings (journal_id, setting_name, set...", Array(5))

File: ojs2/classes/journal/Journal.inc.php line 271
Function: JournalSettingsDAO->updateSetting(Null, "title", Array(1), "string", True)

File: ojs2/classes/site/ImportOJS1.inc.php line 231
Function: Journal->updateSetting("title", Array(1), "string", True)


Also, there are still many warnings that remain of the following form (haven't listed them all):

Warning: Missing argument 2 for Issue::setShowCoverPage(), called in ojs2/classes/site/ImportOJS1.inc.php on line 822 

Warning: Missing argument 2 for Article::setCoverageGeo(), called in ojs2/classes/site/ImportOJS1.inc.php on line 984

etc.
Comment 11 Alec Smecher 2007-09-28 14:45:57 PDT
Fixed -- though there may be more of the same; this generally needs testing.
Comment 12 Alec Smecher 2007-10-15 07:43:59 PDT
*** Bug 3071 has been marked as a duplicate of this bug. ***
Comment 13 Alec Smecher 2007-10-16 11:39:41 PDT
*** Bug 3074 has been marked as a duplicate of this bug. ***