We are moving to Git Issues for bug tracking in future releases. During transition, content will be in both tools. If you'd like to file a new bug, please create an issue.

Bug 2960 - Back-port and test LDAP plugin from OJS
Back-port and test LDAP plugin from OJS
Status: RESOLVED FIXED
Product: OCS
Classification: Unclassified
Component: General
2.1.2
PC Linux
: P1 normal
Assigned To: Alec Smecher
: 2929 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-25 13:36 PDT by Alec Smecher
Modified: 2009-05-26 05:36 PDT (History)
5 users (show)

See Also:
Version Reported In:
Also Affects:


Attachments
Patch against OCS pre-2.1.2 CVS (20.33 KB, patch)
2009-04-07 14:06 PDT, Alec Smecher
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Alec Smecher 2007-07-25 13:36:18 PDT
Back-port and test LDAP plugin from OJS.
Comment 1 Tyler Mitchell 2007-11-23 11:17:47 PST
Hi there - any progress on this one?  Or hints on how to hack it to work?  We're ready to go into production with OCS and this is my last missing piece.
Comment 2 Tyler Mitchell 2008-01-22 13:39:37 PST
just pinging for further status...
Comment 3 Alec Smecher 2008-01-29 12:48:07 PST
*** Bug 2929 has been marked as a duplicate of this bug. ***
Comment 4 Alec Smecher 2008-05-23 10:25:40 PDT
Deferring from OCS 2.1 -- however, with the localization changes in place, the auth plugin *should* drop in without changes. The auth plugin code from OJS 2.x may have been disturbed accidentally since OCS 2.0 was originally forked. Interested in hearing back from anyone who tries this.
Comment 5 Alec Smecher 2009-04-07 14:06:34 PDT
Created attachment 1658 [details]
Patch against OCS pre-2.1.2 CVS
Comment 6 Alec Smecher 2009-04-07 14:08:24 PDT
Anyone using LDAP interested in testing this? AFAIK, this plugin should drop right into an OCS 2.1.1 installation without problems.