Bug 2680 - Automate assignment of Section Editors
Automate assignment of Section Editors
Status: RESOLVED FIXED
Product: OJS
Classification: Unclassified
Component: Editors
2.2
Macintosh Mac OS X 10.0
: P1 normal
Assigned To: PKP Support
http://pkp.sfu.ca/ojs/demo/present/in...
: 3947 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-03-01 00:16 PST by John Willinsky
Modified: 2008-12-27 14:25 PST (History)
1 user (show)

See Also:
Version Reported In:
Also Affects:


Attachments
Patch against pre-2.2 CVS (25.95 KB, patch)
2007-07-27 09:29 PDT, Alec Smecher
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description John Willinsky 2007-03-01 00:16:37 PST
To automate the selection of Section Editors, have the SE for that Section assigned one at a time to the submissions as they come in. They will be listed as per current set up, and can be deleted, of course, and another one added. 

http://pkp.sfu.ca/ojs/demo/present/index.php/demojournal/manager/editSection/1

Section Editors       
Botton of chart

[ ] Automatically assign Section Editors to manage submissions in this section.
      Assign them to manage (O) Review stage, ( ) Editing stage, ( ) Review and Editing stages.

Following on Gunther Eysenbach's suggestion.
Comment 1 Alec Smecher 2007-03-15 14:04:37 PDT
Implemented, with the exception of the UI addition for the section form (pending introduction of the section_settings table)
Comment 2 Alec Smecher 2007-03-15 14:07:45 PDT
When completed, this should be synced with OCS (bug entry #2663, roughly)
Comment 3 Alec Smecher 2007-07-05 15:04:53 PDT
At the risk of making more work for myself, wouldn't it make more sense to allow Managers to choose editorial vs. reviewing tasks for Editors on a per-Editor basis? That way they could e.g. designate two editors as Reviewing sec eds and a third as an Editing sec ed.
Comment 4 John Willinsky 2007-07-05 23:49:12 PDT
Excellent idea. It suggests having a list of Section Editors appear under Section Editors, with a four-part pulldown

Section Editors
Section Editors to be assigned to manage review and/or editiing of submissions to this section, either manually by editor, or automatically in rotation, with possible over-ride by editor.
                                 
[X] Section EditorA      [Assign Manually                       ]
[X] Section EditorB      [Auto-assign to review              ] 
[X] Section EditorC      [Auto-assign to editing             ]
[X] Section EditorD      [Auto-assign to review/editing ]
[  ] Section EditorE       [Assign Manually                       ]

[Save]
Comment 5 Alec Smecher 2007-07-27 09:29:55 PDT
Created attachment 244 [details]
Patch against pre-2.2 CVS
Comment 6 Alec Smecher 2007-07-27 09:30:56 PDT
Implemented -- and not necessary to sync with OCS2 since the distinction between reviewing and editing SecEd assignments doesn't apply.
Comment 7 Alec Smecher 2008-12-27 14:25:09 PST
*** Bug 3947 has been marked as a duplicate of this bug. ***