Bug 2679 - Copyedit and Layout Comments, Proofreading Corrections Email Options
Copyedit and Layout Comments, Proofreading Corrections Email Options
Status: RESOLVED FIXED
Product: OJS
Classification: Unclassified
Component: Copyeditors and Proofreaders
2.x
Macintosh Mac OS X 10.0
: P1 normal
Assigned To: PKP Support
http://pkp.sfu.ca/ojs/demo/present/in...
: 2678 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-02-28 23:44 PST by John Willinsky
Modified: 2013-05-29 15:10 PDT (History)
2 users (show)

See Also:
Version Reported In:
Also Affects:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description John Willinsky 2007-02-28 23:44:49 PST
The "Save and email" button should lead to an email template, which has the title of hte submission as its title and any text that has been added to the textbox as its body. It should be from the person logged in, and be directed as follows, depending on role of the person sending it. The sender can delete any undesired addresses of course.

Copyedit Cmments 
TO: Editor/Author, Copyeditor/Editor, Copyeditor/Author 

Layout Comments
TO: Editor/Copyeditor, Layout Editor/Copyeditor, Layout Editor/Editor

Proofreading Comments
TO: Author/Editor/Layout Editor,  Author/Editor/Proofreader,  Proofreader/Editor/Layout Editor,  Author/Proofreader/Layout Editor
Comment 1 Alec Smecher 2007-03-01 08:42:34 PST
*** Bug 2678 has been marked as a duplicate of this bug. ***
Comment 2 Alec Smecher 2007-07-31 16:17:19 PDT
John, the "Save and Email" button may potentially send out several messages, with each individually addressed to one recipient by name. However, we only want to bring up a single email compose window. This means the compose window would contain {$recipientName} in place of the actual recipient's name, since those will be filled in when sending, one for each recipient.

This will probably be confusing to senders who won't know that the name will be filled in upon sending.

To avoid this, I'd suggest that we don't individually address each message; rather, the comments should go to all recipients in a single message.
Comment 3 John Willinsky 2007-08-01 18:10:47 PDT
Agreed, no designated recepient for these emails.
Comment 4 Alec Smecher 2007-10-01 15:46:21 PDT
Deferring from 2.2.
Comment 5 Alec Smecher 2013-05-29 15:10:03 PDT
Zombie entry; superseded by 3.0 UI/UX work.