Bug 2657 - Conference Registration
Conference Registration
Status: RESOLVED FIXED
Product: OCS
Classification: Unclassified
Component: User Interface
2.0
Macintosh Mac OS X 10.0
: P1 normal
Assigned To: PKP Support
http://pkp.sfu.ca/ocs2/checkout/index...
: 2516 2523 2528 2533 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-02-17 16:23 PST by John Willinsky
Modified: 2007-03-27 14:17 PDT (History)
1 user (show)

See Also:
Version Reported In:
Also Affects:


Attachments
User view of Registration page (82.50 KB, application/msword)
2007-02-20 19:49 PST, John Willinsky
Details
Further identificaition of Scheduled Conference (93.00 KB, application/msword)
2007-03-26 22:03 PDT, John Willinsky
Details

Note You need to log in before you can comment on or make changes to this bug.
Description John Willinsky 2007-02-17 16:23:25 PST
A. Conference Manager has a Registration management link for each Scheduled Conference as follows...

Name of Scheduled Conference
» Conference Tracks
» Organizing Team
» Setup
» Registration
» Stats & Reports
» Roles

B. Registration resembles Subscriptions in OJS2
http://pkp.sfu.ca/ojs/demo/present/index.php/demojournal/manager/subscriptions

Registrations
.......
REGISTRATIONS    REGISTRATION TYPES    REGISTRATION POLICIES


C. Registation Types 
SHOULD WORK LIKE THIS...
http://pkp.sfu.ca/ojs/demo/present/index.php/demojournal/manager/subscriptionTypes

D. Edit Registration Type
http://pkp.sfu.ca/ojs/demo/present/index.php/demojournal/manager/editSubscriptionType/3

Name of Type*
Description
Cost*
Currency*
Date to close this registration type
Code for free registration [     ] (E.g., XYZ123)

E. PAGE FOR POLICIES

Registration Policies

Registration Manager
If a name is entered here, it will appear, along with the details, under Registration in About the Conference for Scheduled Conferences

Name	
Email	
Phone	
Fax	
Mailing Address

Registation Information
The Registration Types and fee structure will be automatically placed under Registrations on the About the Conferenece page for Current Conferences, along with the name and contact information for the Registration Manager. Additional information about registration, such as methods of payment or support for subscribers in developing countries, can be added here. 

F. http://pkp.sfu.ca/ocs2/checkout/index.php/john/fasc/director/eventSetup/4
DELETE 4.2 Conference Registration

G. http://pkp.sfu.ca/ocs2/checkout/index.php/john/fasc/user/register
Register
CHANGE...
Fill in this form to register with this conference.
TO...
Fill in this form to first register with this conference website. Then you will be able to enrol as a registrant to attend a scheduled conference, by clicking on Conference Registration under the scheduled conference listing. 

DELETE...
SIgnature 

H. http://pkp.sfu.ca/ocs2/checkout/index.php/test2/PAPER
DELETE TITLE Table of Contents
ADD Conference Registration to list...

» Overview
» Call for Papers (January 18, 2007 - February 18, 2007)
» Conference Registration
» Proposal Submission
» Presentations and Presenters 
» Program
» Conference Organizers & Key Partners

I. When you click on Conference Registration, it requires you to be logged in...
If the user is not logged in at that point...

Log In

Username
Password
[ ] Remember my username and password

» If you are not yet registered with this conference website, click here as this is the first step in signing up to attend the conference.
» Forgot your password?

This should lead to the Conference Registration page in both cases (that is, after logging in or registering).
Comment 1 Alec Smecher 2007-02-19 13:16:34 PST
*** Bug 2516 has been marked as a duplicate of this bug. ***
Comment 2 Alec Smecher 2007-02-19 15:05:26 PST
*** Bug 2523 has been marked as a duplicate of this bug. ***
Comment 3 Alec Smecher 2007-02-19 15:29:49 PST
We also need to implement the attendee's (reader's) view of the registration process. (May be part of Juan's Paypal plugin.)
Comment 4 John Willinsky 2007-02-20 16:07:14 PST
G. http://pkp.sfu.ca/ocs2/checkout/index.php/john/fasc/user/register
Register
CHANGE...
Fill in this form to register with this conference.
TO...
Complete this form to register with this conference website. To register to attend the conference, log in and go to Conference Registration.

DELETE...
SIgnature

THIS REPLACES E. on REGISTRATION POLICIES

Registration Policies

Access Management
[ ] Registration with the conference website, at no cost, is required to view presentations for this conference.
[ ] Registration to attend the conference is required to view presentations for this conference.

THE FIRST OPTIONS MEAN WHEN ONE CLICKS ON A PRESENTATION TITLE IT SHOULD NOT SAY AS IT DOES NOW "SUBSCRIBERS ONLY" BUT "Register with conference website, at no cost, to view conference materials" AND THE SECOND PRODUCES "Registration to attend the conference is required to view conference materials"

Registration Information
Information on access policies and other aspects of conference registration can be added here to appear on the Conference Registration page.
[
[
[

Registration Manager
A Conference Manager can be designated as a Registration Manager, with name and contact information appearing on the Conference Registration page for this scheduled conference.

Name    
Email   
Phone   
Fax     
Mailing Address

 
Comment 5 John Willinsky 2007-02-20 17:04:50 PST
Registration Policies

ADD BELOW ACCESS MANAGEMENT IN Comment #4
Payment Options
[ ] PayPal
[ ] Printable Invoice, payable to Registration Manager
    Instructions for registrant's handliing of invoice.
    [
    [

Comment 6 John Willinsky 2007-02-20 19:12:54 PST
http://pkp.sfu.ca/ocs2/checkout/index.php/test2/PAPER
ADD CONTACT, BASED ON PRINCIPAL CONTACT AND TECHNICAL SUPPORT FROM SETUP, TO SCHEDULED CONFERENCE HOMEPAGE.

» Overview
» Call for Papers (January 18, 2007 - February 18, 2007)
» Conference Registration
» Proposal Submission
» Presentations and Presenters 
» Program
» Conference Organizers & Key Partners
» Contact
Comment 7 John Willinsky 2007-02-20 19:49:00 PST
Created attachment 129 [details]
User view of Registration page

This is the user interface for the Registration process.
Comment 8 Alec Smecher 2007-03-02 12:12:01 PST
I need to make sure this covers the following settings that were moved out of Setup: enableRegistration, registrationName, registrationEmail, registrationPhone,
registrationFax, registrationMailingAddress
Comment 9 Alec Smecher 2007-03-02 16:04:17 PST
*** Bug 2533 has been marked as a duplicate of this bug. ***
Comment 10 Alec Smecher 2007-03-20 16:27:15 PDT
John, one point for clarification regarding the user view of the registration process:

The current "register" link acts just like the one in OJS, i.e. it's used when a user wants to create an account for himself. This includes reviewers, presenters, registrants, the editorial team, etc. We can't conflate that with registering for the event -- we should either keep the "create an account" process separate from the "register for the event" process, or we should very carefully combine the two, making sure that the resulting form still serves other users e.g. reviewers who are not attending but need accounts nonetheless. This means revisiting much of comment #1, comment #4, and comment #7. We need to support the following processes:

1. A new visitor to the website wants to register to attend; this will involve creating an account and also registering/paying for the conference

2. An existing user (e.g. a reviewer or a reader) wants to register to attend the conference

3. A new visitor to the website wants to become a reviewer, presenter, etc. but not register to attend.


Comment #4, comment #6, and parts of comment #1 made obsolete by setup overhaul; comment #5 superceded by Juan's implementation (we'll need to synch implementations between OJS and OCS if that doesn't suit); comment #8 and parts of comment #1 implemented;

Some of the above implemented. Here is a summary of what still needs attention:

- Comment #1: D. "Code for free registration [     ] (E.g., XYZ123)"
- User view of registration process (including disambiguation as per the top of this comment)

The registration management forms and related options also need reviewing; I'm not sure how implemented they are.
Comment 11 Alec Smecher 2007-03-20 17:16:24 PDT
*** Bug 2528 has been marked as a duplicate of this bug. ***
Comment 12 John Willinsky 2007-03-20 20:30:47 PDT
I think your advice to keep "create an account with this website" process separate from the "register for the event" process is best. 
Comment 13 Alec Smecher 2007-03-22 15:39:36 PDT
I'd suggest that we require users to have "Reader" accounts (to use OJS terminology) in order to register; this will allow us to keep track of a lot more information and will prevent us from getting into trouble with "anonymous" registrations that later want to be associated with an account, e.g. for paper access.
Comment 14 John Willinsky 2007-03-22 22:14:12 PDT
It may seem a little odd to ask someone to become a "reader" with the website before they can become "registered to attend a scheduled conference." As opposed to asking them first "to create an account" with the website, prior to "registering to attend a scheduled conference" or "submitting a presentation." Still, there may be situations where the directors insist that "readers" of conference materials "create an account" as a reader first. Words, words, words, as Hamlet said.
Comment 15 Alec Smecher 2007-03-26 14:08:15 PDT
Regarding comment #13 and comment #14: What I meant was that users must have OCS accounts before they're allowed to register and pay. (Of course, we can and should streamline this process so that it flows smoothly for registrants who don't yet have accounts.)

This means that the "Conference Registration Information" section in Attachment #129 [details] doesn't make sense any more -- this information will and must be the same as the account information. (I don't think there's any value in allowing someone to register with different user information than they're using with their account, is there?)
Comment 16 John Willinsky 2007-03-26 22:03:04 PDT
Created attachment 145 [details]
Further identificaition of Scheduled Conference
Comment 17 Alec Smecher 2007-03-27 14:17:33 PDT
Implemented. Paypal/payment support porting from OJS remains, but I'm opening a new entry for that.