We are moving to Git Issues for bug tracking in future releases. During transition, content will be in both tools. If you'd like to file a new bug, please create an issue.

Bug 2490 - Update Subscription Type Public Display Column and Code to Match Updates in Bug 2213
Update Subscription Type Public Display Column and Code to Match Updates in B...
Status: RESOLVED FIXED
Product: OJS
Classification: Unclassified
Component: General
2.2
All All
: P1 enhancement
Assigned To: Michael Felczak
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-19 18:14 PST by Michael Felczak
Modified: 2008-03-06 11:33 PST (History)
1 user (show)

See Also:
Version Reported In:
Also Affects:


Attachments
Patch against pre-2.2 CVS (6.65 KB, patch)
2007-09-27 20:59 PDT, Michael Felczak
Details | Diff
Patch #2 against pre-2.2 CVS (5.84 KB, patch)
2007-09-28 13:10 PDT, Michael Felczak
Details | Diff
Patch against pre-2.2 CVS (6.93 KB, patch)
2008-03-06 11:33 PST, Michael Felczak
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Felczak 2006-12-19 18:14:08 PST
Initially, this field was intended and used in an affirmative sense, as in
"this subscription type should be publicly visible". Since this will be
true for most subscription types, the UI was changed to "this subscription type should *not* be publicly visible" to not have to require Subscription Managers to have to click on the checkbox each time that they create a new subscription type.

To further clarify this new behaviour, update the following for consistency:
- rename the database column
- rename the getPublic method
- modify the getPublic code to refer to the new column name
- rename the calls to the new getPublic method
Comment 1 Michael Felczak 2007-09-27 20:59:10 PDT
Created attachment 288 [details]
Patch against pre-2.2 CVS
Comment 2 Michael Felczak 2007-09-27 20:59:32 PDT
Fixed.
Comment 3 Michael Felczak 2007-09-28 12:50:17 PDT
- Improve column name.

- Since subscription types will now be visible in areas (i.e. payments) other than just About, modify the following text:

"This subscription type will not appear under Subscriptions in About the Journal."

to something more generic, i.e.:

"This subscription type will not be publicly visible (e.g., under Subscriptions in About the Journal)."
Comment 4 Michael Felczak 2007-09-28 13:10:50 PDT
Created attachment 289 [details]
Patch #2 against pre-2.2 CVS
Comment 5 Michael Felczak 2007-09-28 13:12:22 PDT
Fixed.
Comment 6 Alec Smecher 2008-02-29 13:23:43 PST
Michael, is attachment #288 [details] superceded by attachment #289 [details]? If so, could you mark attachment #288 [details] as obsolete? Thanks.
Comment 7 Michael Felczak 2008-03-06 11:33:26 PST
Created attachment 522 [details]
Patch against pre-2.2 CVS

Combined patch includes both cumulative patches.