Bug 2407 - Display name in emails should be quoted if it has special characters
Display name in emails should be quoted if it has special characters
Status: RESOLVED FIXED
Product: OJS
Classification: Unclassified
Component: Open Journal Systems
2.2
PC Linux
: P2 normal
Assigned To: PKP Support
: 2935 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-21 16:36 PDT by Shubhash Wasti
Modified: 2007-06-29 19:13 PDT (History)
1 user (show)

See Also:
Version Reported In:
Also Affects:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Shubhash Wasti 2006-09-21 16:36:08 PDT
We have had a few problems because of OJS not quoting the display name when
sending out emails. For example, we had a journal where the journal manager
entered the principal contact's name as LASTNAME, FIRSTNAME. When an author
submits an article, the acknowledgement email appears to come from
LASTNAME@SOMEDOMAIN, FIRSTNAME <CONTACT@EMAIL.ADDRESS>. The reason for this is
because the mail server considers it to be two addresses and expands the one
before the comma to canonical address resulting in weird looking "From" header.
I believe that the same problem exists if the recipient's name has special
characters, in which case, the results are worse as OJS tries to send emails to
non-existent addresses.
Comment 1 Alec Smecher 2006-09-22 01:40:19 PDT
Thanks, Shubhash; I'll try to address this for our next release.
Comment 2 Alec Smecher 2006-10-11 06:09:30 PDT
Corrected (classes/mail/Mail.inc.php 1.35)
Comment 3 Alec Smecher 2007-06-29 19:13:45 PDT
*** Bug 2935 has been marked as a duplicate of this bug. ***