Bug 2383 - Event and email log entries use bad static optimization
Event and email log entries use bad static optimization
Status: RESOLVED FIXED
Product: OJS
Classification: Unclassified
Component: Editors
2.2
PC Linux
: P2 normal
Assigned To: Alec Smecher
: 2373 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-06 15:49 PDT by Alec Smecher
Modified: 2006-10-09 07:29 PDT (History)
1 user (show)

See Also:
Version Reported In:
Also Affects:


Attachments
Patch against OJS 2.1.1 (1.31 KB, patch)
2006-09-06 15:51 PDT, Alec Smecher
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Alec Smecher 2006-09-06 15:49:53 PDT
Event and email log entries use incorrect "static" optimization; this results in
all fetched names and email addresses for a request appearing to be the same.
Comment 1 Alec Smecher 2006-09-06 15:51:45 PDT
Created attachment 80 [details]
Patch against OJS 2.1.1
Comment 2 Alec Smecher 2006-09-06 15:51:57 PDT
Corrected.
Comment 3 Alec Smecher 2006-09-06 16:18:41 PDT
Also affected with similar flaws: classes/journal/Journal.inc.php and
classes/article/ArticleComment.inc.php. The attached patch does not correct
these additional flaws.
Comment 4 Alec Smecher 2006-10-09 07:29:50 PDT
*** Bug 2373 has been marked as a duplicate of this bug. ***