Bug 2346 - Expedite feature not working in 2.1.1
Expedite feature not working in 2.1.1
Status: RESOLVED FIXED
Product: OJS
Classification: Unclassified
Component: Authors
2.2
PC Linux
: P2 normal
Assigned To: Alec Smecher
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-24 09:00 PDT by Alec Smecher
Modified: 2007-04-15 12:20 PDT (History)
2 users (show)

See Also:
Version Reported In:
Also Affects:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alec Smecher 2006-07-24 09:00:46 PDT
The Expedite feature is not working in OJS 2.1.1. First blood for the new release.
Comment 1 Alec Smecher 2006-07-24 09:01:48 PDT
Fixed in CVS. See
http://research2.csci.educ.ubc.ca/cgi-bin/cvsweb/ojs2/classes/submission/editor/EditorAction.inc.php.diff?r1=1.37;r2=1.38
for a patch to correct this.
Comment 3 Ramon Fonseca 2007-01-31 14:16:05 PST
I couldn't apply this patch:

I copied and saved as a .txt file. 
Then executed the command 

patch -p0 --dry-run < editoractionpatch.txt

This is the ouptut:

can't find file to patch at input line 3
Perhaps you used the wrong -p or --strip option?
The text leading up to this was:
--------------------------
|--- ojs2/classes/submission/editor/EditorAction.inc.php        2006/06/12 23:25:54     1.37
|+++ ojs2/classes/submission/editor/EditorAction.inc.php        2006/07/24 16:01:06     1.38
--------------------------
File to patch: ojs-2.1.1/classes/submission/editor/EditorAction.inc.php
patching file ojs-2.1.1/classes/submission/editor/EditorAction.inc.php
patch: **** malformed patch at line 10:
Comment 4 Alec Smecher 2007-01-31 15:25:42 PST
Hi Ramón,

This one needs -p1 instead of -p0 to strip the ojs2/ out of the path. (Depending on how patches were generated, they'll generally need either a -p1 or -p0.)