Bug 2280 - index.php/index/user and index.php/journal_path/user behaviour confusing
index.php/index/user and index.php/journal_path/user behaviour confusing
Status: RESOLVED WONTFIX
Product: OJS
Classification: Unclassified
Component: User Interface
2.4.x
All All
: P2 normal
Assigned To: Alec Smecher
: 5202 6563 8224 (view as bug list)
Depends on:
Blocks: 6656
  Show dependency treegraph
 
Reported: 2006-06-27 12:15 PDT by Juan Pablo Alperin
Modified: 2013-05-08 13:08 PDT (History)
7 users (show)

See Also:
Version Reported In:
Also Affects:


Attachments
Patch against OJS pre-2.3 CVS (3.72 KB, patch)
2009-05-27 15:45 PDT, Alec Smecher
Details | Diff
Patch against OCS pre-2.3 CVS (4.35 KB, patch)
2009-05-27 15:53 PDT, Alec Smecher
Details | Diff
Patch against OMP pre-release (2.70 KB, patch)
2009-05-27 15:53 PDT, Alec Smecher
Details | Diff
Patch against OJS 2.3: Remove {$siteTitle} journal title above site admin (655 bytes, patch)
2009-10-27 12:09 PDT, Alec Smecher
Details | Diff
Patch against OCS pre-2.3 CVS (457 bytes, patch)
2009-10-27 12:10 PDT, Alec Smecher
Details | Diff
Patch against OMP pre-release (689 bytes, patch)
2009-10-27 12:12 PDT, Alec Smecher
Details | Diff
Patch against OJS 2.3.4 (543 bytes, patch)
2011-05-02 17:30 PDT, Michael Felczak
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Juan Pablo Alperin 2006-06-27 12:15:44 PDT
a few points that have confused me regarding these menus:

The first is that I don't think that the Site Administrator link should fall under the heading "My Journals".  
"My Journals" should be reserved for the hosted journals and a separate heading name should be used 
for "Open Journal Systems->site Administrator".  

Secondly. I have found it confusing that the "User Home" button takes you to two different paths.  I 
understand that one is the "Journal User Home" and the other is the "Site User Home" but since I am 
logged in as the site administrator (and the journal manager simultaneously) then I have the 
expectation that my "User Home" will have menu items for both.  i.e. I think that all "User Home" links 
should take me to index.php/index/user.

Finally, to add further confusion, on the page: index.php/JMIR/user there is a link to "Show My Journals" 
which takes you to index.php/index/user (i.e. the other user home).
Comment 1 Matthew Crider 2008-11-06 15:54:40 PST
Is there any resolution to this second point, or are we just ignoring it?  I think its a big usability no-no to change the meaning of the 'User Home' link depending if you are in a journal or not, and that it should always go to the site-level user home page.  I know you can click on the 'My journals' link in the user block, but something doesn't sit well with me about this design decision.
Comment 2 Juan Pablo Alperin 2008-11-06 16:01:45 PST
I actually still think these are both relevant points, but I had figured these were not so important, so I marked them as wontfix.  Its actually probably because I had them marked as 2.x and were not being noticed by anyone.  I will reopen the bug and mark as to-do for 2.3, so we at least think/talk about it.
Comment 3 Alec Smecher 2009-05-27 15:45:50 PDT
Created attachment 1873 [details]
Patch against OJS pre-2.3 CVS

At least a partial solution:
 - All "User Home" links now go to the site-wide User Home
 - "Site Administrator" now shows up at the top

I have not removed the journal-specific User Home, because it should still be there in case someone does not have any roles within a journal as a quick way to register for them if they are available. This may need future design work, but can defer that for now.
Comment 4 Alec Smecher 2009-05-27 15:53:02 PDT
Created attachment 1874 [details]
Patch against OCS pre-2.3 CVS
Comment 5 Alec Smecher 2009-05-27 15:53:19 PDT
Created attachment 1875 [details]
Patch against OMP pre-release
Comment 6 Alec Smecher 2009-06-01 15:23:08 PDT
Closing for now.
Comment 7 tdthom 2009-10-13 16:15:37 PDT
I recently upgraded to OJS 2.3, and found some elements of this change a bit confusing. I like that "Site Administrator" is up the top and not grouped with the Journal roles. But I do note on my installation the heading link generated by {$siteTitle|escape} returns the Journal title and not the Site title. I am not sure why this is. I resolved my issue by deleting the line:
<h4><a href="{url page="user"}">{$siteTitle|escape}</a></h4>
This heading seemed superfluous anyway.

The change to the behaviour of the "User Home" link is confusing for a site with one journal, and which has redirected main site links to that journal in Site Settings. In such instances a user should only ever see their Journal user home, because from their perspective that is the site. Only the Site Admin should be able to access the Site User Home. Because the style templates only apply at the journal level, it can be very disorientating for a user to click "User Home" and be sent to a site with a different name and style.

I resolved my problems by splitting this bugfix into two patch files (one for the User Home diff and one for the Site Admin diff). I then reversed the patch for the User Home behaviour.
Comment 8 Alec Smecher 2009-10-27 12:09:52 PDT
Created attachment 2553 [details]
Patch against OJS 2.3: Remove {$siteTitle} journal title above site admin
Comment 9 Alec Smecher 2009-10-27 12:10:42 PDT
Created attachment 2554 [details]
Patch against OCS pre-2.3 CVS
Comment 10 Alec Smecher 2009-10-27 12:12:02 PDT
Created attachment 2555 [details]
Patch against OMP pre-release
Comment 11 Alec Smecher 2009-10-27 12:17:41 PDT
Hi tdthom@gmail.com --

I've removed the superfluous heading as per your suggestion (attachments #2553, #2554, #2555). Regarding the site-wide user home replacing the journal-specific one -- I still think this is overall a clearer way of navigating. Is your major concern the styling of the journal being lost? The easiest way to solve this is probably to upload a site-wide stylesheet that matches your journal's style. We're in the process of redesigning the User Home, so we're not likely to provide another interim solution, but let me know if this resolves your concerns in the meantime.
Comment 12 Alec Smecher 2010-03-10 10:37:31 PST
*** Bug 5202 has been marked as a duplicate of this bug. ***
Comment 13 bdgregg 2010-03-10 11:58:15 PST
First, thanks Alex for pointing me to this as I opened bug 5202 on the same topic.

Second, I know this issue is marked as "Resolved Fixed" but if I may encourage it to re-opened, I believe the "User Home" confusion can be cleared up with some "simple" code logic.  I say simple as it seems simple to me but I'm sure coding may be nearly impossible as always.  ;-)

Anyway here's our take on the use of User Home and how it should direct users.
 
If the logged in user is a "Site Administrator" take them to the "Site" user home, as that's usually where they would probably wish to go anyway and all functions for all journals are found there as well.

Now for all the other user roles.
If the logged in user is not a "Site Administrator" and there is only a single journal hosted within the site then take them the only "Journal" user home there is as there is only one journal that they'd be working with anyway.  Else (there's more than one journal), if the user is associated with only a single journal then take them to that journals user home, else (user is associated with more than one journal) take them to the site user home as we're not sure which journal they'd be working on.

So logically:

IF (USER == ROLE.SITEADMIN) {
   // User is a site admin we know where he/she is going.
   USERHOME = SITE.USERHOME
} else {
   // User is not a site admin.
   IF (NUMHOSTEDJOURNALS == 1) {
      // There is only 1 journal.
      USERHOME = JOURNAL.USERHOME
   } else { 
      // There is more than 1 journal
      IF (USER.MEMBERSHIP == 1) {
          // User is member of only 1 of the journals.
          USERHOME = JOURNAL.USERHOME
      } else {
          // User is member of multiple journals in the site.
          USERHOME = SITE.USERHOME
      }
   }
}

I hope my logic sounds right as I believe it would fit most if not all circumstances of single journals as well as multiple journals.

I have looked at the patches described above and those seem to be already incorporated into our OJS version 2.3.1-2 installed here and this is the version that I'm reporting the current user confusion issue with pertaining to a single journal instance.

Thanks,
Brian Gregg
University of Pittsburgh.
Comment 14 Alec Smecher 2010-03-24 13:51:00 PDT
Brian, you're not the only one to give us feedback on this. It's a little tricky at the moment because while it's possible to control a lot of layout issues for the individual journals, it's not for the whole site. This is something we'll be working on in the near future. Re-opening this issue for review.
Comment 15 Michael Felczak 2011-04-27 12:18:48 PDT
*** Bug 6563 has been marked as a duplicate of this bug. ***
Comment 16 Michael Felczak 2011-04-27 12:19:57 PDT
Addtional feedback from James from Bug 6563:

Currently, if the Site Admin sets the Journal Redirect option to a single
journal (in Site Admin -> Site Settings), non-authenticated users are still
brought to eg. http://git/ojs/index.php/index/user when clicking "User Home".
They should be brought to the journal-specific User Home, eg.
http://git/ojs/index.php/test/user.
Comment 17 Michael Felczak 2011-04-27 12:20:40 PDT
Additional feedback from Peter Dietz from Bug 6563:

We have multiple journals on our instance (2.3.x), once the authenticated user
clicks userHome from a journal it takes them to the index/user page, which is
not where they want to go. The user would likely be expecting to go to the
userHome for the current journal, which is what my local modification does. If
they started from the index, and clicked userHome, then they go to index/user.
Comment 18 Michael Felczak 2011-04-27 12:25:57 PDT
For the time being, reverting the navigation bar from:

<li id="userHome"><a href="{url journal="index" page="user"}">

to:

<li id="userHome"><a href="{url page="user"}">

should resolve the problems reported by James and Peter.

It sounds like the main problem for most users is the expectation that User Home will take them to the home page for the journal that they're currently working with. This is consistent with the 'User' breadcrumb.

To reach the My Journals home page and switch to a different journal, users can use the 'My Journals' links. Clicking on User Home while on the My Journals page will simply re-load the page.

This will work the same for regular users as well as JMs and SAs.

In the special case of the SA, if accessing the site admin pages then User Home, User breadcrumb, and My Journals all lead the SA to the My Journals page.

As an aside, it may be worthwhile to rename the current pages to reduce confusion, e.g. journal-specific user home to 'Journal Home' (local) and the My Journals page to 'User Home' (global).
Comment 19 Michael Felczak 2011-05-02 17:30:42 PDT
Created attachment 3502 [details]
Patch against OJS 2.3.4

User Home should link to current journal home
Comment 20 Michael Felczak 2011-05-02 17:32:57 PDT
Still need to revert the navigation bar for OCS. However, this will also require adding a 'My Conferences' link in the User sidebar to mirror OJS navigation.
Comment 21 Juan Pablo Alperin 2011-07-04 13:56:51 PDT
Implemented a solution for OMP, which has site settings within the press context.
https://github.com/pkp/omp/commit/0570aaa7a2e53c17ca636320e8bc0b5241cbaf4a
Comment 22 montyspamnet 2011-07-29 00:32:10 PDT
Further to a comment I made on the forums here would be my suggestion. 

1. Home must always mean the top page of the site. (Usually /). i.e. it is unique. 
2. When you are within a Journal, the Breadcrumb should show the name of that journal (or possibly have the term Journal Home)

Now, if you are at the top of a journal, Asian Culture say, you get this

Home > Asian Culture [ both links take you to the Asian Culture top page - i.e. back to the page you are on]
but it should be 
Home > Asian Culture (Home takes you to / and the second is NOT a clickable link)

But as you go inside Asian Culture you get something like this:

Home > Notifications (with the second taking you back to the same page again)

It should be 
Home > Asian Culture > Notifications
or
Asian Culture > Notifications

(or use a term like Journal Home)
Comment 23 Alec Smecher 2012-08-14 14:47:26 PDT
Deferring to 2.4.1. The solution for this will likely take a page from OMP, after some UI reviews there. The "User Home" in OMP has been removed entirely.
Comment 24 Shubhash Wasti 2013-03-18 12:27:21 PDT
What is the status of this "bug"? 
From comment #19, it appears that "user home" should stay within the current journal, but in version 2.4.2, it still jumps outside the current journal.
Comment 25 Alec Smecher 2013-03-18 12:30:06 PDT
Shubhash, we've had comments on both sides of the fence, so I'm hesitant to make a further change. Going forward, the entire "Use Home" is going to be removed in favour of an OMP-style dashboard and numerous refinements to the overall site layout. Meanwhile, I'd suggest maintaining a local modification if the current behavior doesn't suit your install.

A proper solution will be coming to OJS 3.0.
Comment 26 Alec Smecher 2013-05-08 13:08:17 PDT
*** Bug 8224 has been marked as a duplicate of this bug. ***