Bug 2078 - Issue title is not showing up on the cover or ToC for Special Issue
Issue title is not showing up on the cover or ToC for Special Issue
Status: RESOLVED DUPLICATE of bug 2702
Product: OJS
Classification: Unclassified
Component: User Interface
2.1.1
Macintosh Mac OS X 10.0
: P2 normal
Assigned To: PKP Support
http://journals.sfu.ca/pocol/index.ph...
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-16 10:45 PST by John Willinsky
Modified: 2007-06-08 12:29 PDT (History)
1 user (show)

See Also:
Version Reported In:
Also Affects:


Attachments
Patch against OJS 2.1.1 (585 bytes, patch)
2007-06-08 12:28 PDT, Alec Smecher
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description John Willinsky 2006-02-16 10:45:47 PST
The title for special issues appear directly beneath the Vol X No Y (YYYY) and above the dotted line with 
the same size font used for the section titles, on both the cover page and if there is one and the ToC page.
Comment 1 Alec Smecher 2006-02-21 10:59:06 PST
The "Issue Identification" pulldown for this issue shows "Volume, Number, Year"
--  to display the title, choose "Title Only". Is this not expected behavior?
Comment 2 John Willinsky 2006-02-21 11:11:38 PST
The "Issue Identification" pulldown is for the "regular" identification of issues, while the title option was 
intended to add a title for that one issue to the selected issue identification.
Comment 3 Alec Smecher 2006-04-13 14:05:52 PDT
Issue title is now displayed as a subheading when it is not used as the primary
identification.
Comment 4 Ramon Fonseca 2007-05-18 08:57:28 PDT
Title for special issues is noly displayed when issue is accessed through the archives, not when it's the current issue.
Comment 5 Michael Felczak 2007-05-25 14:27:26 PDT
Hi Ramon, I just tried but could not reproduce this bug with the current CVS. Are you running 2.1.1?

Please note that the options and display behaviour for issue data was modified for 2.2 as part of Bug #2291. 
Comment 6 Ramon Fonseca 2007-06-08 08:23:37 PDT
When viewing the Current Issue page, the custom Title of the issue is not displayed. 

The title is only displayed when viewing the archives...

here's an example of a TOC without the issue title (just numbers) - 
http://proxy.furb.br/ojs/index.php/atosdepesquisa/index

When viewing the archives, the title shows up
http://proxy.furb.br/ojs/index.php/atosdepesquisa/issue/view/26

Any patches or modifications that could be done to display the title on the current issue page?
Comment 7 Alec Smecher 2007-06-08 11:28:44 PDT
This has already been corrected in CVS, but other changes mean that it won't port nicely back into OJS 2.1.1. Is this a critical issue, Ramón, or can you wait for OJS 2.2?

*** This bug has been marked as a duplicate of bug 2702 ***
Comment 8 Ramon Fonseca 2007-06-08 12:02:47 PDT
(In reply to comment #7)
> This has already been corrected in CVS, but other changes mean that it won't
> port nicely back into OJS 2.1.1. Is this a critical issue, Ramón, or can you
> wait for OJS 2.2?
> 
> *** This bug has been marked as a duplicate of bug 2702 ***
> 

For the people managing those journals yes... is there anything that can be done that is easy to do and won't need to be done after an upgrade to 2.2?
Comment 9 Alec Smecher 2007-06-08 12:28:48 PDT
Created attachment 205 [details]
Patch against OJS 2.1.1
Comment 10 Alec Smecher 2007-06-08 12:29:51 PDT
Ramón, please try the attached patch -- it should add the subheading when the current issue's TOC is displayed on the journal homepage. (If the problem appears under other conditions, please let me know.)