We are moving to Git Issues for bug tracking in future releases. During transition, content will be in both tools. If you'd like to file a new bug, please create an issue.

Bug 1760 - Custom Review Forms (patch)
Custom Review Forms (patch)
Status: RESOLVED DUPLICATE of bug 3547
Product: OJS
Classification: Unclassified
Component: Submissions and Publishing
2.x
All All
: P3 enhancement
Assigned To: Alec Smecher
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-04 19:06 PDT by Kevin Jamieson
Modified: 2008-06-09 18:43 PDT (History)
1 user (show)

See Also:
Version Reported In:
Also Affects:


Attachments
Patch against OJS 2.0 (166.09 KB, text/plain)
2005-08-04 19:06 PDT, Kevin Jamieson
Details
OJS database schema changes (1.95 KB, application/rtf)
2005-08-04 19:08 PDT, Kevin Jamieson
Details
Updated patch against OJS 2.0 (99.87 KB, patch)
2005-08-12 11:18 PDT, Alec Smecher
Details | Diff
Updated patch against CVS just prior to 2.0.2 (87.69 KB, patch)
2005-08-26 09:47 PDT, Alec Smecher
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Kevin Jamieson 2005-08-04 19:06:24 PDT
My name is Felix Candelario and i am have developed a feature that I
would like included in the next version of OJS. I've created a form
that allows journal managers to create review forms that will be
utilized by reviewers when completing reviews.

As you may know each journal has specific questions or scales that
will help them gauge the quality of a submission. This form will let
editors duplicate these questions online. I suggest you login and add
questions (please don't delete existing questions). You can then
create another reviewer and assign a submission to yourselves.

----------------------------------------------------------------------

Requires approval from the powers that be before it can be incorporated into the
trunk (and may require further changes to be accepted, developed either by PKP
or Felix).

If approved, patch (which is against 2.0) should be reviewed and applied. This
may need to be done manually due to the number of changes and new conventions
introduced since OJS 2.0.
Comment 1 Kevin Jamieson 2005-08-04 19:06:56 PDT
Created attachment 34 [details]
Patch against OJS 2.0
Comment 2 Kevin Jamieson 2005-08-04 19:08:07 PDT
Created attachment 35 [details]
OJS database schema changes

(I haven't checked the patch to see if these schema changes were added to
ojs_schema.xml or not)
Comment 3 John Willinsky 2005-08-07 14:22:16 PDT
I think we should implement the Review Form as provided, with the following changes. We are using a 
series of default set ups for users, given the number of new journal editors using OJS. Given lack of 
agreement on Review Forms, a simple default form that focuses on comments rather than scales, is my 
preference for OJS.

"Review Form" link on Management Pages should lead to a Review Form page that comes before the one  
that has been prepared, as follows...
-----
Review Form

(O) Default Review Form 
The default review form presents reviewers with two open text boxes, one designated, "Author and 
Editor," and one, "Editor Only," into which reviewers can type or paste their comments. Reviewers are 
also able to upload documents and will have to select a recommendation for the submission under 
review.

(  ) Custom Review Form    [Create/Edit]
A custom form can be created for reviewers using multiple choice and open text items.

[SAVE]    [PREVIEW CURRENT FORM]
-------

Custom Review Form

CHANGE...
Question
TO...
Item

Question text *
TO...
Item text *

CHANGE...
Question type *
TO...
Item type *

CHANGE...
Fillin
TO...
Open text

Private Question
TO...
Restrictions

CHANGE...
Check this box if the answer to this question should be visible only to the editor.
TO...
Check if response to item is for the editor only.

CHANGE...
Your answer to this question will only be shared with the editor.
TO...
Only the editor will see the response to this item.

ALSO, for all items in the custom form that do not have Restrictions checked, the item and its response 
will be subject to [Import Peer Review] button in Editor/Author Correspondence...
http://pkp.sfu.ca/ojs/demo/present/index.php/demojournal/editor/viewEditorDecisionComments/22.
Comment 4 Alec Smecher 2005-08-09 09:33:18 PDT
The patch as attached doesn't contain all the necessary code; ie
ReviewQuestionDAO is not included. I have requested Felix to re-generate it.
Comment 5 Alec Smecher 2005-08-12 10:58:18 PDT
Received a full tarball of Felix's modified version. I've put the attachment
online at http://www.smecher.bc.ca/alec/ojs/car.tar.gz; it's too big to add as a
Bugzilla attachment. (Will attach patch once I've generated it.)
Comment 6 Alec Smecher 2005-08-12 11:18:07 PDT
Created attachment 36 [details]
Updated patch against OJS 2.0

Updated patch generated by Alec against OJS 2.0 codebase.
Comment 7 Alec Smecher 2005-08-26 09:47:44 PDT
Created attachment 38 [details]
Updated patch against CVS just prior to 2.0.2

Code overhaul in progress; questions made journal-specific; forms made
optional. Terminology changes mentioned here have mostly not yet been applied.
Comment 8 Alec Smecher 2005-08-26 09:48:48 PDT
Deferring this issue to a future release.
Comment 9 Alec Smecher 2006-01-08 10:07:48 PST
Deferred again.
Comment 10 Alec Smecher 2008-06-09 18:43:20 PDT

*** This bug has been marked as a duplicate of bug 3547 ***