We are moving to Git Issues for bug tracking in future releases. During transition, content will be in both tools. If you'd like to file a new bug, please create an issue.

Bug 1324 - The Editor/Author Correspondence would do better as an Email Template
The Editor/Author Correspondence would do better as an Email Template
Status: RESOLVED FIXED
Product: OJS
Classification: Unclassified
Component: Editors
2.x
Macintosh All
: P2 normal
Assigned To: PKP Support
http://research2.csci.educ.ubc.ca/ojs...
: 1311 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-16 23:26 PST by John Willinsky
Modified: 2006-02-14 11:38 PST (History)
2 users (show)

See Also:
Version Reported In:
Also Affects:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description John Willinsky 2005-03-16 23:26:20 PST
I know this has absorbed a lot of energy getting it right, but Rory's solution for the blind CC to 
Reviewers now seems the obvious way to treat the whole thing, for as it stands, it is half email, half 
comment box, and it isn't clear what has been emailed and what will be emailed. This will solve that 
(finally).

1. THE Editor/Author Correspondence COMMENT BOX WOULD BE REPLACED BY AN EMAIL TEMPLATE, 
with 
IMPORT at the bottom, along with the BCC option for notifying reviewers.
---------

TO
CC
BCC

From
Subject   Editorial Decision
Comment 1 Kevin Jamieson 2005-03-16 23:40:55 PST
I may not be understanding the scope of this request, but we should not be
removing the editor/author comments feature. If this is merely a modification to
allow the editor decision notification (see bug #1311) to be sent from this
page, then that is acceptable.
Comment 2 John Willinsky 2005-03-17 00:27:51 PST
I am suggesting replacing the E/A Comment with a email template function, yes, but I wanted to keep 
the comment box to hold the saved body of the emails which would be very helpful for the author and 
editor to review, especially given the months it takes for revisions to be made. So the SE clicks on the 
[email icon] and goes to the Editor Decision email template, with review import capacity, and email 
reviewer link, or the SE clicks on the [comment icon] to see previous messages to and from author. 
Otherwise, the ability to review the exchange of a month or two ago is not that easy. The Editor 
Decision would like this, with a corresponding set up for Authors, and "Email author" is very clear, like" 
Select decison"

Editor Decision
Select decision    [Select one...]
Decision              Resubmit for review 2005-11-23
Email author       [email icon]  [comment icon] 2005-11-23
Author Version   23-21-AV.doc
Comment 3 Kevin Jamieson 2005-03-17 00:33:31 PST
This sounds like a complete deparature from the current approach. Why is it
being brought up now? I think any such changes would have to be deferred.

I do not agree with removing the Editor/Author comment functionality, nor with
using the comments for purposes other than what it is intended, like saving emails.
Comment 4 John Willinsky 2005-03-17 08:52:57 PST
The changes I am asking us to consider are being brought up for the reasons outlined in my comments 
for this bug (especially #2) and are brought up now rather than earlier because the design balance 
between the comment (record of exchange) and correspondence (email) function has gradually evolved 
with Rory's help to this point. If I am not convincing on the fact that a problem remains with my earlier 
design of E/A, I will rethink my case; if my proposed solution does not work, then let us try some other 
approach. If it needs deferring, that's fine.

On the proposed use of the comment box, for example, I did worry about re-purposing. However, I 
realized that the comment box serves above all as a record for critical input in the editorial process 
(reviews, E/A correspondence, proofreading corrections, etc.). The SE consults the boxes as a record 
through that icon (and less frequently uses it as an input device for that purpose), which is why it 
seemed consistent with what I proposing here. As I have said before, the E/A correspondence is the 
most delicate and important work the editor does, and it is understandable that it would take a lot of 
finetuning on our part to serve that operation well.
Comment 5 Kevin Jamieson 2005-04-06 19:44:56 PDT
*** Bug 1311 has been marked as a duplicate of this bug. ***