We are moving to Git Issues for bug tracking in future releases. During transition, content will be in both tools. If you'd like to file a new bug, please create an issue.

Bug 1311 - EDITOR_REVIEW email & related functions appear to be unused
EDITOR_REVIEW email & related functions appear to be unused
Status: RESOLVED DUPLICATE of bug 1324
Product: OJS
Classification: Unclassified
Component: Editors
2.0
PC Linux
: P2 normal
Assigned To: Alec Smecher
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-16 13:06 PST by Alec Smecher
Modified: 2005-04-06 19:44 PDT (History)
3 users (show)

See Also:
Version Reported In:
Also Affects:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alec Smecher 2005-03-16 13:06:05 PST
EDITOR_REVIEW email template, notifyAuthor functions (SectionEditorAction &
SectionEditorHandler classes) appear not to be used.

(Perhaps this feature was removed from the template during the UI updates.)
Comment 1 Alec Smecher 2005-03-16 13:06:51 PST
Sorry, that should be "appear NOT to be used" in the bug title.
Comment 2 Kevin Jamieson 2005-03-16 13:55:41 PST
Rory, it appears the editor decision to author notification is not used anywhere
in the UI. Is this supposed to be integrated with the comments as with the
editor decision to reviewers notification (which IS currently present)?
Comment 3 Rory Hansen 2005-03-17 00:21:59 PST
Hrm.

I actually don't know.

The function of the notifyAuthor email has been replaced by the ability to 
import peer reviews through comments, and then sending the combined reviews 
(along with the editor's decision) to the author using the Save and Email 
button.

I've just been plugging away at things John has been asking me to do and so I 
guess I didn't realize that that feature is now missing.
Comment 4 Kevin Jamieson 2005-04-06 19:14:25 PDT
John, this seems like something that is a potential bug. Could you comment?
Comment 5 John Willinsky 2005-04-06 19:32:34 PDT
OSJ 2.0 uses the Editor/Author Correspondence to send emails from editor to author, and from author 
to editor. This would eliminate the need for EDITOR_REVIEW email template, however with more 
reflection I proposed in #1324 to turn the E/A C into an email template (now scheduled for 2.X), and 
that still makes sense to me. So the template is not used now -- and the system will work -- but it may 
be in 2.X. 
Comment 6 Kevin Jamieson 2005-04-06 19:44:55 PDT
Okay, will leave the code as is for now and defer changes to #1324

*** This bug has been marked as a duplicate of 1324 ***