Bug 8412

Summary: empty issue and supp file DOI element in CrossRef XML export
Product: OJS Reporter: Bozana Bokan <bozana.bokan>
Component: Plug-insAssignee: PKP Support <pkp-support>
Status: RESOLVED FIXED    
Severity: normal CC: alec, hilton.gibson
Priority: P3    
Version: 2.4.3   
Hardware: All   
OS: All   
Version Reported In: Also Affects:

Description Bozana Bokan 2013-09-02 06:13:05 PDT
If there is no DOI for an issue or supp file, there is the empty DOI element in the CrossRef XML export, which shouldn't be.
Comment 1 Bozana Bokan 2013-09-09 05:40:02 PDT
empty issue and supp file DOI element in CrossRef XML export
https://github.com/pkp/ojs/commit/209acc9fcc232c3e8f3b195f03a55864d7d83b3d
Comment 2 Alec Smecher 2013-09-09 15:56:40 PDT
Thanks, Bozana; also ported to master.
Comment 3 Alec Smecher 2013-09-09 15:58:02 PDT
CrossRef empty elements fix ported to master
https://github.com/pkp/ojs/commit/e2971ef3e599bfc0b2384ceab931648511064c07
Comment 4 Jason Nugent 2013-11-14 06:05:05 PST
*** Bug 8470 has been marked as a duplicate of this bug. ***