Bug 8224

Summary: Change "User home" link functionality
Product: OJS Reporter: James MacGregor <jmacgreg>
Component: User InterfaceAssignee: PKP Support <pkp-support>
Status: RESOLVED DUPLICATE    
Severity: normal CC: alec, jason.nugent
Priority: P3    
Version: 2.4.3   
Hardware: All   
OS: All   
Version Reported In: Also Affects:

Description James MacGregor 2013-05-08 12:30:37 PDT
Currently the "User Home" link in the navbar goes to the site index user home page. Previously (though I'm not sure how far long ago ...) it used to go to the User Home page for the journal the user was currently navigating (and if on the install's index page, then to the site index user home). While this makes sense for multi-journal installs, it's a little problematic for single-journal installs, especially for those who don't change any of the site-level CSS/title fields. 

This has come up with a couple of journals we host; right now I've been changing 

{url journal="index" page="user"}

to 

{url page="user"}

in templates/common/navbar.tpl, line 16. Maybe there's a better overall solution though -- even simply checking to see if the site's journal redirect option has been set, in which case the latter rather than the former URL would be used. Any thoughts?
Comment 1 Jason Nugent 2013-05-08 12:55:39 PDT
Hi James,

Out of curiosity, how does this play with bug #8094, specifically commit #238?  So far as I can tell, there isn't a User Home any more :)

I mention this because the URL that you're using now, {url page="user"}, would no longer function.  The Dashboard appears to have become the new landing spot.

For 2.4.x, I'd be inclined to send Users to {url page="index"} which currently has a test to see if there is a Journal in the current context.  If there is, users end up on the Journal landing page.  The site otherwise.
Comment 2 Alec Smecher 2013-05-08 13:08:17 PDT
See bug #2280 for some discussion of this. I'd prefer if we didn't oscillate back and forth between the two solutions, as either is likely to make someone unhappy -- the proper solution will go into 3.0 by making use of the Dashboard as Jason describes.

*** This bug has been marked as a duplicate of bug 2280 ***