Bug 7950

Summary: Problem assigning participants with Chrome on Windows
Product: OMP Reporter: Alec Smecher <alec>
Component: User InterfaceAssignee: beghelli <bruno.beghelli>
Status: RESOLVED FIXED    
Severity: normal CC: bruno.beghelli, ruestn
Priority: P3    
Version: 1.0   
Hardware: All   
OS: All   
Version Reported In: Also Affects:
Attachments: Proposed patch against pkp-lib omp-stable-1_0

Description Alec Smecher 2012-10-02 14:26:32 PDT
See http://pkp.sfu.ca/support/forum/viewtopic.php?f=40&t=9134 for details. Apparently switching to IE worked around the problem.
Comment 1 beghelli 2012-10-02 14:39:06 PDT
Tested with Chrome version 21.0.1180.89 in Windows and it's working.

Will wait until tkarpin answers which version of Chrome he is getting into trouble.
Comment 2 beghelli 2012-10-03 07:57:01 PDT
Also tested with Chrome 22 in Windows and not managed to reproduce the error.
Comment 3 Nick Ruest 2012-11-06 11:54:40 PST
I can confirm and reproduce this bug on an Ubuntu machine with both Firefox and Chrome, as well as a Mac with both Firefox and Chrome.
Comment 4 Alec Smecher 2012-11-06 11:58:57 PST
Nick, that's probably not the same problem as this report. Can you check to see if your web server/PHP error log contains anything relevant?
Comment 5 Nick Ruest 2012-11-06 12:07:22 PST
I believe it is the same problem as is described in the forum topic linked above. We are able to add participants in on a Windows XP machine using Firefox just fine. However, on the other platforms listed earlier we are unable to select from either dropdown box (http://i.imgur.com/8M82x.png). 

I have also checked my logs, and I have nothing in my error log relevant to the issue.
Comment 6 Alec Smecher 2012-11-07 10:40:16 PST
Nick, the entire dev team uses various stripes of Firefox, so it's surprising to hear of a problem with that browser. Could you install Firebug and check the console for errors when you hit that page and try to select the pulldown? Do you have the same problem on the OMP testdrive described at <http://pkp.sfu.ca/omp_demo>?
Comment 7 Alec Smecher 2012-11-23 09:01:21 PST
Bruno, there are some additional details on what platforms people are having trouble with here:
http://pkp.sfu.ca/support/forum/viewtopic.php?f=40&t=9134
Comment 8 beghelli 2012-12-03 02:32:47 PST
Sorry guys, I was testing only locally. Today I finally tried remotely and the bug appears, even in Firefox under linux. 

I managed to reproduce it locally too, simulating low bandwidth and high latency. Obviously it's something related with that, and I will fix it.
Comment 9 beghelli 2012-12-03 05:31:37 PST
Created attachment 3894 [details]
Proposed patch against pkp-lib omp-stable-1_0
Comment 10 beghelli 2012-12-03 05:37:12 PST
It was not a problem with high latency and low bandwidth.

The problem was already fixed in master by another fix that I did for another bug. That's why I was not being able to reproduce it, because I was using master branch. Sorry again.

The proposed patch should fix the problems with the drop downs.
Comment 11 Alec Smecher 2012-12-14 13:32:00 PST
Bruno, I think this is ready to be closed? I've added it to the Recommended Patches list.
Comment 12 beghelli 2012-12-17 09:58:21 PST
Alec, as far as I tested, it's working ok now. I think we can close this bug.