Bug 7544

Summary: session_is_registered function is removed in PHP 5.4
Product: OJS Reporter: Jason Nugent <jason.nugent>
Component: GeneralAssignee: PKP Support <pkp-support>
Status: RESOLVED FIXED    
Severity: normal CC: alec, jmacgreg, molavy2003, sosacelina
Priority: P3    
Version: 2.4.0   
Hardware: All   
OS: All   
Version Reported In: Also Affects:
Attachments: Patch against OJS 2.3.x

Description Jason Nugent 2012-06-07 02:50:21 PDT
The Session class currently relies on a test for session_is_registered() which is deprecated in PHP 5.3 and removed in 5.4.  

See:

http://pkp.sfu.ca/support/forum/viewtopic.php?f=8&t=8701
Comment 1 Alec Smecher 2012-06-07 09:39:58 PDT
Created attachment 3789 [details]
Patch against OJS 2.3.x

The session_is_registered and session_unregister calls are unneeded, I think; please test this patch and let me know if it works.
Comment 2 Jason Nugent 2012-06-07 09:44:25 PDT
Hi Alec,

Against 2.3.7 it seems to work fine.

Cheers,

Jason
Comment 3 Alec Smecher 2012-06-07 11:15:02 PDT
Removed unnecessary session_... func calls
https://github.com/pkp/pkp-lib/commit/2c2a380d9babb84ef00f837dd09636b2b47fb06f
Comment 4 sosacelina 2012-09-05 09:50:48 PDT
buenas yo instale el ojs 2.3.7 en un servidor windows 2003, durante la instalaciĆ³n y configuraciĆ³n del software no huno problema, se alojo la revista sin ningun problema pero cuando dese ingresar al nombre de la revista dandole al link de esta me da el error Fatal error: Call to undefined function session_is_registered() in C:\xampp\htdocs\ojs\lib\pkp\classes\session\Session.inc.php on line 64 igualmente me da este mismo error al darle click al link gestor de la revista y darle click al link de salir, agradeceria mucho el que me pudieran ayudar con este problema
Comment 5 Alec Smecher 2012-09-05 09:56:42 PDT
sosacelina, apply the patch attached to this bug entry to solve the problem. (Alternately, install OJS 2.4.0, which has the patch included.)
Comment 6 Jason Nugent 2012-09-15 03:47:45 PDT
*** Bug 7913 has been marked as a duplicate of this bug. ***
Comment 7 Jason Nugent 2012-09-16 05:58:54 PDT
*** Bug 7913 has been marked as a duplicate of this bug. ***
Comment 8 Alec Smecher 2013-04-24 11:04:39 PDT
*** Bug 8208 has been marked as a duplicate of this bug. ***
Comment 9 James MacGregor 2013-04-24 11:09:49 PDT
(In reply to comment #8)
> *** Bug 8208 has been marked as a duplicate of this bug. ***

Heh, so many duplicates. Alec, I just cherry-picked your previous commit to my ojs-stable-2_3 lib/pkp checkout; it applies cleanly and fixes the problem. Did you want me to commit this and add to the 2.3 Recommended Patches list?
Comment 10 Alec Smecher 2013-04-24 11:23:03 PDT
Sure, fine with me.
Comment 11 Alec Smecher 2013-07-31 11:09:02 PDT
Removed unnecessary session_... func calls
https://github.com/pkp/pkp-lib/commit/e80f42ac05db44b07754278c272ae6237941f199
Comment 12 Alec Smecher 2013-07-31 15:12:02 PDT
Removed unnecessary session_... func calls
https://github.com/pkp/pkp-lib/commit/be5189d450563e5e7caac322070f3a754e46d11f