We are moving to Git Issues for bug tracking in future releases. During transition, content will be in both tools. If you'd like to file a new bug, please create an issue.

Bug 6747

Summary: reviewer and review pages are all kinds of broken
Product: OMP Reporter: Juan Pablo Alperin <juan>
Component: ReviewersAssignee: Juan Pablo Alperin <juan>
Status: RESOLVED FIXED    
Severity: normal CC: alec, jerico.dev, mattcrider, pkp-support
Priority: P3    
Version: 1.0   
Hardware: All   
OS: All   
Version Reported In: Also Affects:

Description Juan Pablo Alperin 2011-07-08 17:13:53 PDT
the grid is not working properly, the steps aren't submitting correctly. all kinds of broken.
Comment 1 Juan Pablo Alperin 2011-07-11 13:11:40 PDT
*** Bug 6410 has been marked as a duplicate of this bug. ***
Comment 3 Juan Pablo Alperin 2011-07-11 22:53:11 PDT
*** Bug 6374 has been marked as a duplicate of this bug. ***
Comment 4 Juan Pablo Alperin 2011-07-11 23:10:32 PDT
*** Bug 6531 has been marked as a duplicate of this bug. ***
Comment 5 Juan Pablo Alperin 2011-07-14 15:24:14 PDT
*** Bug 6172 has been marked as a duplicate of this bug. ***
Comment 6 Juan Pablo Alperin 2011-07-21 14:50:04 PDT
MONOGRAPH_FILE constants unecessary using hex (renumber all and introduce review_attachment constant)
https://github.com/pkp/omp/commit/3d5390f873056b993ddc4ede5e1e67d58be1020c
Comment 7 Juan Pablo Alperin 2011-07-21 14:50:04 PDT
include assocType/assocId in file upload and management classes
https://github.com/pkp/omp/commit/825d032cafdc362221bfbb20ebe473e6927b9876
Comment 8 Juan Pablo Alperin 2011-07-21 14:50:05 PDT
introduce more options to PKPSubmissionFileDAO::_getInternally (uploaderId/UserGroupId, assocType/Id)
https://github.com/pkp/pkp-lib/commit/6fd65bed4ba7048e6080d94a21b3dc17ec034696
Comment 9 Juan Pablo Alperin 2011-07-21 14:50:05 PDT
include revision in review_round_files primary key
https://github.com/pkp/omp/commit/980651d63e366b3debc5040d4a62506f2dd2c211
Comment 10 Juan Pablo Alperin 2011-07-21 14:50:05 PDT
make grids load the right files and just generally work. Also fix editor decision forms.
https://github.com/pkp/omp/commit/40bff10eb2ee13d697065db28c0ebfe5036672ff
Comment 11 Juan Pablo Alperin 2011-07-21 14:50:05 PDT
make revisions across stages get a new file id and point the source to the revision.
https://github.com/pkp/omp/commit/42788345560fc61ff4564e9f638a7b3007f8632e
Comment 12 Juan Pablo Alperin 2011-07-21 14:50:05 PDT
introduce fileStage = REVIEW_ATTACHMENT (not used yet)
https://github.com/pkp/omp/commit/c1f8dbfd90c4fb57aa856657b1c99f538a8ff5c1
Comment 13 Juan Pablo Alperin 2011-07-21 14:50:05 PDT
Fixes to file uploading and new MonographFileManager::copyFileToFileStage method.
https://github.com/pkp/omp/commit/d3a14e81acc013dd0a84d20f03720e925d63574a
Comment 14 Juan Pablo Alperin 2011-07-22 16:30:02 PDT
allow editor decisions to be taken in past stages (lightly tested, but might cause some instability if decisions taken out of order)
https://github.com/pkp/omp/commit/fa8dc8550ef853d603a0dd2fef067a97cc320075
Comment 16 Juan Pablo Alperin 2011-08-04 20:09:39 PDT
*** Bug 6230 has been marked as a duplicate of this bug. ***
Comment 17 Juan Pablo Alperin 2011-08-05 23:50:05 PDT
Review Assignment was not being inserted
https://github.com/pkp/omp/commit/b5e94d7c467538718e651da7993e45d4f2ac1136
Comment 18 Juan Pablo Alperin 2011-08-05 23:50:06 PDT
allow revisions grid to be viewed by authors and update to new definition of FileSignoffGridHandler
https://github.com/pkp/omp/commit/b1a8e687924390ae95611cb5e751d5d01a412796
Comment 19 Juan Pablo Alperin 2011-08-05 23:50:07 PDT
Assign author to Submission Stage
https://github.com/pkp/omp/commit/af71428fa9d9fde68d12c7ab9edab1d61ab34394
Comment 20 Juan Pablo Alperin 2011-08-05 23:50:07 PDT
Misc fixes to review stage
https://github.com/pkp/omp/commit/64677a8035b913d03065784f1faadf46ed91b564
Comment 21 Juan Pablo Alperin 2011-08-07 23:00:10 PDT
flip parameters of ReviewAssignmentRequired policy
https://github.com/pkp/omp/commit/862b0d1a19bdb459676132fc65865379a823d24f
Comment 22 Juan Pablo Alperin 2011-08-09 13:30:25 PDT
*** Bug 6233 has been marked as a duplicate of this bug. ***
Comment 23 Juan Pablo Alperin 2011-08-09 13:37:08 PDT
*** Bug 6412 has been marked as a duplicate of this bug. ***
Comment 24 Juan Pablo Alperin 2011-08-11 21:00:03 PDT
add reviewer modal was not supposed to have tabs. Provide link to other types of adding modals and provide method for reloading form content with other forms.
https://github.com/pkp/omp/commit/d51ba6f0de595f648557a803a4d60557c4628c2d
Comment 25 Juan Pablo Alperin 2011-08-11 21:00:03 PDT
, *6713*, *others* a round of many but minor tune ups to the workflow, mostly visual but some functional
https://github.com/pkp/omp/commit/c3c47f4af195c5ff2270c0efae3a6be7f1f18508
Comment 26 Juan Pablo Alperin 2011-08-11 21:00:04 PDT
editors should not be allowed to add review attachments.
https://github.com/pkp/omp/commit/3c0cbc317eb08b048966329e71648124e4d95490
Comment 27 Juan Pablo Alperin 2011-08-12 00:20:04 PDT
load round tabs via ajax and use TabHandler
https://github.com/pkp/omp/commit/dcd0ad95c56f83cfe8dc5bb080e64d7b351a6429
Comment 28 Alec Smecher 2011-08-12 17:05:02 PDT
SE unassigned list was showing submissions in unassigned series
https://github.com/pkp/omp/commit/bf9f16b81bbf6d2296dfc4a96ce3cc3c9da0f1c4
Comment 29 Juan Pablo Alperin 2011-08-15 22:15:03 PDT
HACK. HACK. hide stage participants and use toggle to show. Plus
https://github.com/pkp/omp/commit/47f3da59fd0a465e355c934c9c8b92fc5714cb1d
Comment 30 Juan Pablo Alperin 2011-08-15 22:15:03 PDT
prevent id clash in review round info when multiple rounds
https://github.com/pkp/omp/commit/af7e189e2aac06d6368131670d6d41bd4b2e0f76
Comment 31 Juan Pablo Alperin 2011-08-15 22:15:03 PDT
ReviewerComment was not fetched correctly. parameters misnamed.
https://github.com/pkp/omp/commit/2a5e131aca1afdf4dbc05a5e48198b3a027d2beb
Comment 32 Juan Pablo Alperin 2011-08-15 22:15:03 PDT
competing interests action
https://github.com/pkp/omp/commit/f40fe6e479aedf89948477906d63b91ef3a2068b
Comment 33 Juan Pablo Alperin 2011-08-22 00:45:10 PDT
various fixes to reviewer grid (cell states, setting response due date, reminder action)
https://github.com/pkp/omp/commit/57c4ef9217c84c642b8f1dc2ca9b7836de13385f
Comment 34 Juan Pablo Alperin 2011-09-05 17:50:41 PDT
closing in favor of more specific bugs