Bug 5505

Summary: GenericPlugin.inc.php load error
Product: OJS Reporter: James MacGregor <jmacgreg>
Component: Plug-insAssignee: jerico <jerico.dev>
Status: RESOLVED FIXED    
Severity: normal CC: jerico.dev, pkp-support
Priority: P5    
Version: 2.3.3   
Hardware: PC   
OS: Mac OS X 10.4   
Version Reported In: 2.3.2 Also Affects:

Description James MacGregor 2010-06-16 11:07:58 PDT
I'm seeing the following error while trying to load pages within OJS (I'm guessing it's part of the ongoing plugin restructuring to PKP WAL, but I figure I'd report it anyway): 

[Wed Jun 16 11:07:16 2010] [error] [client 127.0.0.1] ojs2 has produced an error\n  Message: WARNING: include_once(/Users/jmacgreg/git/ojs/classes/plugins/GenericPlugin.inc.php): failed to open stream: No such file or directory\n  In file: /Users/jmacgreg/git/ojs/lib/pkp/includes/functions.inc.php\n  At line: 30\n  Stacktrace: \n  Server info:\n   OS: Darwin\n   PHP Version: 5.3.1\n   Apache Version: Apache/2.2.14 (Unix) mod_ssl/2.2.14 OpenSSL/0.9.8l DAV/2 PHP/5.3.1 mod_fastcgi/2.4.2\n   DB Driver: mysql\n   DB server version: 5.1.38, referer: http://git/ojs/index.php/index/user
[Wed Jun 16 11:07:16 2010] [error] [client 127.0.0.1] ojs2 has produced an error\n  Message: WARNING: include_once(): Failed opening '/Users/jmacgreg/git/ojs/classes/plugins/GenericPlugin.inc.php' for inclusion (include_path='.:/Users/jmacgreg/git/ojs/classes:/Users/jmacgreg/git/ojs/pages:/Users/jmacgreg/git/ojs/lib/pkp:/Users/jmacgreg/git/ojs/lib/pkp/classes:/Users/jmacgreg/git/ojs/lib/pkp/pages:/Users/jmacgreg/git/ojs/lib/pkp/lib/adodb:/Users/jmacgreg/git/ojs/lib/pkp/lib/phputf8:/Users/jmacgreg/git/ojs/lib/pkp/lib/pqp/classes:/Users/jmacgreg/git/ojs/lib/pkp/lib/smarty:.:/usr/lib/php')\n  In file: /Users/jmacgreg/git/ojs/lib/pkp/includes/functions.inc.php\n  At line: 30\n  Stacktrace: \n  Server info:\n   OS: Darwin\n   PHP Version: 5.3.1\n   Apache Version: Apache/2.2.14 (Unix) mod_ssl/2.2.14 OpenSSL/0.9.8l DAV/2 PHP/5.3.1 mod_fastcgi/2.4.2\n   DB Driver: mysql\n   DB server version: 5.1.38, referer: http://git/ojs/index.php/index/user
Comment 1 jerico 2010-06-16 22:34:34 PDT
Hi James,

this looks like an outdated include path. What exactly is the URL you're trying to open? I couldn't reproduce the problem with arbitrary URLs.

Florian
Comment 2 James MacGregor 2010-06-16 22:53:13 PDT
(In reply to comment #1)
> Hi James,
> 
> this looks like an outdated include path. What exactly is the URL you're trying
> to open? I couldn't reproduce the problem with arbitrary URLs.
> 
> Florian

Hi Florian, 

It happens no matter which page I load. I'm pretty confident that my install (both ojs and lib/pkp) is up-to-date, and I'm on master, but I don't mind doing a fresh checkout if you think I might've messed something up.
Comment 3 James MacGregor 2010-06-16 22:58:07 PDT
Wait, nevermind -- I figured it out. I had an old, external plugin installed (the latexRender plugin from the plugin galley), which of course hasn't been updated like the other included plugins, and so it was trying to call the old genericPlugin.inc.php file. If this will break old, non-included plugins, we'll probably want to include a notice of such in the release notes, and maybe post something to the forum.
Comment 4 jerico 2010-06-18 03:56:35 PDT
Hi James, no, that's a problem. All plug-in changes should be backwards compatible. No legacy/community plug-in should break due to my plug-in changes. That's a very important requirement. It's nice that you came across this bug before our users hit it. I'll have a look at the latexRender plugin and leave this issue assigned to me. I'm onto something else currently.
Comment 5 jerico 2010-06-24 15:36:46 PDT
Hi James,

this was really a bug that had to do with the "absolute include path" change. The fix is here: http://github.com/pkp/pkp-lib/commit/029624a7f2c5f3dd5e50929f10556f9275d9720c

Did this fix the issue?
Comment 6 James MacGregor 2010-06-24 15:45:16 PDT
(In reply to comment #5)
> Hi James,
> 
> this was really a bug that had to do with the "absolute include path" change.
> The fix is here:
> http://github.com/pkp/pkp-lib/commit/029624a7f2c5f3dd5e50929f10556f9275d9720c
> 
> Did this fix the issue?

Yep, that did the trick and everything looks great now -- thanks, Florian!