We are moving to Git Issues for bug tracking in future releases. During transition, content will be in both tools. If you'd like to file a new bug, please create an issue.

Bug 5279

Summary: Crossref Export plugin should send a few more elements
Product: OJS Reporter: James MacGregor <jmacgreg>
Component: Plug-insAssignee: James MacGregor <jmacgreg>
Status: RESOLVED DUPLICATE    
Severity: normal CC: alec, ales.kladnik, juan
Priority: P5    
Version: 3.0   
Hardware: PC   
OS: Mac OS X 10.3   
Version Reported In: 2.3.4 Also Affects: OJS 2.3.4
Bug Depends on: 6957    
Bug Blocks:    

Description James MacGregor 2010-03-30 22:52:01 PDT
The Crossref export plugin doesn't include page numbers when the journal enables them. It should include at a minimum the first article page like so: 

<pages>
<first_page>2268</first_page>
</pages>

Full sample XML files for journals, but also conferences and monographs, can be viewed here: http://www.crossref.org/schema/info/samples/4.3.0_samples/. 

(Courtesy of http://pkp.sfu.ca/support/forum/viewtopic.php?f=8&t=5876&start=0)
Comment 1 Alec Smecher 2010-07-20 12:45:24 PDT
Deferring.
Comment 2 Ales Kladnik 2011-07-08 04:10:33 PDT
Following the Crossref XML schema <pages> need to be specified. I used regular expressions search&replace in Notepad++ to correct the output of Crossref plugin:

Find: <publisher_item><item_number>([S0-9]*)-([S0-9]*)</item_number></publisher_item>
Replace with: <pages><first_page>\1</first_page><last_page>\2</last_page></pages>

also fill in the name of registrant (publisher name) somewhere near the beginning of the XML file:
<registrant>registrant-name</registrant>

-Ales
Comment 3 James MacGregor 2011-09-12 14:02:30 PDT
(In reply to comment #2)
> Following the Crossref XML schema <pages> need to be specified. I used regular
> expressions search&replace in Notepad++ to correct the output of Crossref
> plugin:
> 
> Find:
> <publisher_item><item_number>([S0-9]*)-([S0-9]*)</item_number></publisher_item>
> Replace with:
> <pages><first_page>\1</first_page><last_page>\2</last_page></pages>
> 
> also fill in the name of registrant (publisher name) somewhere near the
> beginning of the XML file:
> <registrant>registrant-name</registrant>
> 
> -Ales

Thanks for the comment, Ales. I'll try and get a fix to this shortly. One note: the registrant information will be automatically supplied if you add a publisher to Journal Setup Step 1.5.
Comment 4 Ales Kladnik 2011-09-12 23:41:19 PDT
Thank you James!
Regarding the registrant name: I have all three fields filled-in in the Setup step 1.5, but the <registrant> doesn't get generated. Also, I noticed that in the About page I have no information displayed about Publisher: http://www.ias-iss.org/ojs/IAS/about
There is a PKP support forum post describing the same problem here: http://pkp.sfu.ca/support/forum/viewtopic.php?f=8&t=7569&p=30661#p30661
-ales
Comment 5 Juan Pablo Alperin 2013-10-14 09:50:09 PDT
Include:
- page numbers
- link to full-text
- link to license (where possible)
- funder information (if possible, look into FundRef)
Comment 6 Juan Pablo Alperin 2013-10-14 09:52:24 PDT
See other CrossRef related bugs (not necessarily dependencies): 
- bug #6615
- bug #6625
- bug #7026
Comment 7 Juan Pablo Alperin 2014-03-26 13:41:59 PDT

*** This bug has been marked as a duplicate of bug 8648 ***