Bug 3590

Summary: allow for different Creative Commons license choices
Product: OJS Reporter: James MacGregor <jmacgreg>
Component: User InterfaceAssignee: PKP Support <pkp-support>
Status: RESOLVED DUPLICATE    
Severity: enhancement CC: a.marchitelli, alec, ctgraham, nef, wujastyk
Priority: P1    
Version: 2.4.x   
Hardware: PC   
OS: Mac OS X 10.0   
Version Reported In: Also Affects:

Description James MacGregor 2008-06-18 15:15:55 PDT
Under Journal Setup Step 3.2, a JM can choose to display a Creative Commons License, but choosing this only enables a hard-coded piece of footer.tpl to be displayed; this means that if a JM wants to change the type of license they are using from CC Attribution 3.0, they have to edit footer.tpl. 

Creativecommons.org has a good "Choose a license" page (http://creativecommons.org/license/) that results in embeddable HTML code. I would recommend providing JMs with a link to this page from step 3.2, along with a subsequent text box to embed the resulting code. 

Change the following: 

[] For journals that offer immediate or delayed open access, include a Creative Commons license with all published work at the appropriate time.

to:

[] For journals that offer immediate or delayed open access, include a Creative Commons license with all published work at the appropriate time. First, <a href="http://creativecommons.org/license">choose an appropriate license</a> from the Creative Commons website; and then paste the resulting embeddable code into the text box below.
Comment 1 Alec Smecher 2008-06-24 10:05:06 PDT
Deferring.
Comment 2 Andrea Marchitelli 2012-02-26 04:13:02 PST
Any news about this feature?
Comment 3 Alec Smecher 2012-09-21 17:26:16 PDT
No news yet, Andrea, though it's on our list.
Comment 4 Clinton Graham 2014-08-18 12:58:06 PDT
I think this is superseded and resolved by bug 8578.
Comment 5 Alec Smecher 2014-08-18 14:05:14 PDT
Agreed, thanks.

*** This bug has been marked as a duplicate of bug 8578 ***