Bug 3205

Summary: Payments and "comments to editor" on step 5
Product: OJS Reporter: Alec Smecher <alec>
Component: Plug-insAssignee: Juan Pablo Alperin <juan>
Status: RESOLVED FIXED    
Severity: normal CC: jmacgreg
Priority: P1    
Version: 2.2.1   
Hardware: PC   
OS: Linux   
Version Reported In: Also Affects:
Attachments: fixes comment #2
Patch against pre-2.2.1 CVS

Description Alec Smecher 2007-12-31 09:45:56 PST
The payments system uses the same "comments to editor" field on step 5 as the usual submission process uses on step 1. It should either 1) not use the same field, or not display it twice, or 2) if it's decided that displaying the field twice is OK, the TinyMCE plugin needs to know about it so that it can be displayed a second time with WYSIWYG.
Comment 1 Alec Smecher 2007-12-31 15:15:18 PST
Juan, if the "Comments To Editor" form is not displayed on submission Step 5 (i.e. if author fees are disabled), any existing comments to the editor (i.e. entered on Step 1) are deleted. Could you add a patch for this as soon as you have a sec? The eventual resolution described in the main entry can wait.
Comment 2 Alec Smecher 2007-12-31 15:16:28 PST
*** Bug 3204 has been marked as a duplicate of this bug. ***
Comment 3 Juan Pablo Alperin 2008-02-07 09:58:02 PST
Created attachment 498 [details]
fixes comment #2

This takes care of comment #2, but I agree that a new field needs to be created in the DB to hold the waiver reason, instead of recycling the use of the comment field.  Should be trivial to fix, but this patch allows for a fix without the need for someone to upgrade their DB schema in the meantime.
Comment 4 Alec Smecher 2008-02-08 10:15:36 PST
Thanks, Juan -- FYI, making use of the article_settings table, it's no longer necessary to change the database schema in order to store additional metadata.
Comment 5 Alec Smecher 2008-02-19 17:19:24 PST
Created attachment 513 [details]
Patch against pre-2.2.1 CVS

Fixed patch, which appears to have been missing a line.
Comment 6 Alec Smecher 2008-02-19 17:22:47 PST
Already fixed.